aboutsummaryrefslogtreecommitdiffstats
path: root/community/firefox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/firefox/APKBUILD')
-rw-r--r--community/firefox/APKBUILD599
1 files changed, 450 insertions, 149 deletions
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index ee112d67d9c..ed259071e9c 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -1,31 +1,43 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=firefox
-pkgver=90.0.2
-# Date of release, YY-MM-DD for metainfo file (see package())
-_releasedate=2021-07-22
+pkgver=124.0.1
+_releasedate=2024-03-22
pkgrel=0
pkgdesc="Firefox web browser"
url="https://www.firefox.com/"
-# s390x, mips64 and riscv64 blocked by rust and cargo
+# s390x blocked by lld
# armhf: https://bugzilla.mozilla.org/show_bug.cgi?id=1680495
+# riscv64: vpx symbol is missing #15412
arch="x86_64 armv7 aarch64 x86 ppc64le"
license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
+# ffmpeg 6 -> 112
+depends="
+ ffmpeg-libavcodec
+ mesa-egl
+ mesa-gl
+ pciutils-libs
+ "
+_llvmver=17
makedepends="
alsa-lib-dev
automake
bsd-compat-headers
cargo
- cbindgen>=0.18.0
- clang-dev
+ cbindgen
+ clang$_llvmver
+ clang$_llvmver-libclang
+ compiler-rt
+ dbus
dbus-glib-dev
- ffmpeg-dev
+ gettext
gtk+3.0-dev
hunspell-dev
- icu-dev>=64.2
+ icu-dev
libevent-dev
- libidl-dev
+ libffi-dev
libjpeg-turbo-dev
libnotify-dev
libogg-dev
@@ -33,50 +45,65 @@ makedepends="
libtool
libvorbis-dev
libvpx-dev
- libxt-dev
+ libwebp-dev
libxcomposite-dev
- llvm-dev
+ libxt-dev
+ lld
+ llvm$_llvmver-dev
m4
mesa-dev
+ mesa-dri-gallium
nasm
nodejs
nspr-dev
- nss-dev>=3.44.1
- nss-static
+ nss-dev
+ patchelf
+ pciutils
+ pipewire-dev
+ pulseaudio-dev
+ py3-zstandard
python3
+ scudo-malloc
sed
+ wasi-sdk
wireless-tools-dev
- yasm
+ xvfb-run
zip
- libffi-dev
- libwebp-dev
- pipewire-dev
- gettext
- pulseaudio-dev
"
-
-source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
- stab.h
-
- fix-fortify-system-wrappers.patch
- fix-tools.patch
- mallinfo.patch
-
+subpackages="$pkgname-intl"
+case "$CARCH" in
+riscv64) ;;
+*) subpackages="$subpackages $pkgname-dbg" ;;
+esac
+source="$pkgname-$pkgver.tar.xz::https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
+ crash-reporting-ptrace.patch
disable-moz-stackwalk.patch
+ fix-fortify-system-wrappers.patch
fix-rust-target.patch
fix-webrtc-glibcisms.patch
- fd6847c9416f9eebde636e21d794d25d1be8791d.patch
- allow-custom-rust-vendor.patch
-
- firefox.desktop
- firefox-safe.desktop
- disable-neon-in-aom.patch
+ force-can-use-pack-relative-relocs.patch
+ icu74.patch
+ lfs64.patch
+ no-ccache-stats.patch
+ ppc-musttail.patch
+ python-deps.patch
+ res_nquery.patch
+ rust-lto-thin.patch
+ riscv64-no-lto.patch
sandbox-fork.patch
- sandbox-sched_setscheduler.patch
sandbox-largefile.patch
+ sandbox-sched_setscheduler.patch
+ sqlite-ppc.patch
- avoid-redefinition.patch
+ stab.h
+
+ firefox.desktop
+ distribution.ini
+ mozilla-location.keys
+ vendor-prefs.js
"
+# tests are hard to run
+options="!check"
_mozappdir=/usr/lib/firefox
@@ -85,6 +112,175 @@ ldpath="$_mozappdir"
sonameprefix="$pkgname:"
# secfixes:
+# 119.0-r0:
+# - CVE-2023-5721
+# - CVE-2023-5722
+# - CVE-2023-5723
+# - CVE-2023-5724
+# - CVE-2023-5725
+# - CVE-2023-5726
+# - CVE-2023-5727
+# - CVE-2023-5728
+# - CVE-2023-5729
+# - CVE-2023-5730
+# - CVE-2023-5731
+# 103.0-r0:
+# - CVE-2022-2505
+# - CVE-2022-36314
+# - CVE-2022-36315
+# - CVE-2022-36316
+# - CVE-2022-36317
+# - CVE-2022-36318
+# - CVE-2022-36319
+# - CVE-2022-36320
+# 102.0-r0:
+# - CVE-2022-2200
+# - CVE-2022-34468
+# - CVE-2022-34469
+# - CVE-2022-34470
+# - CVE-2022-34471
+# - CVE-2022-34472
+# - CVE-2022-34473
+# - CVE-2022-34474
+# - CVE-2022-34475
+# - CVE-2022-34476
+# - CVE-2022-34477
+# - CVE-2022-34478
+# - CVE-2022-34479
+# - CVE-2022-34480
+# - CVE-2022-34481
+# - CVE-2022-34482
+# - CVE-2022-34483
+# - CVE-2022-34484
+# - CVE-2022-34485
+# 101.0-r0:
+# - CVE-2022-1919
+# - CVE-2022-31736
+# - CVE-2022-31737
+# - CVE-2022-31738
+# - CVE-2022-31739
+# - CVE-2022-31740
+# - CVE-2022-31741
+# - CVE-2022-31742
+# - CVE-2022-31743
+# - CVE-2022-31744
+# - CVE-2022-31745
+# - CVE-2022-31747
+# - CVE-2022-31748
+# 100.0.2-r0:
+# - CVE-2022-1529
+# - CVE-2022-1802
+# 100.0-r0:
+# - CVE-2022-29909
+# - CVE-2022-29910
+# - CVE-2022-29911
+# - CVE-2022-29912
+# - CVE-2022-29914
+# - CVE-2022-29915
+# - CVE-2022-29916
+# - CVE-2022-29917
+# - CVE-2022-29918
+# 99.0-r0:
+# - CVE-2022-1097
+# - CVE-2022-24713
+# - CVE-2022-28281
+# - CVE-2022-28282
+# - CVE-2022-28283
+# - CVE-2022-28284
+# - CVE-2022-28285
+# - CVE-2022-28286
+# - CVE-2022-28287
+# - CVE-2022-28288
+# - CVE-2022-28289
+# 98.0-r0:
+# - CVE-2022-0843
+# - CVE-2022-26381
+# - CVE-2022-26382
+# - CVE-2022-26383
+# - CVE-2022-26384
+# - CVE-2022-26385
+# - CVE-2022-26387
+# 97.0.2-r0:
+# - CVE-2022-26485
+# - CVE-2022-26486
+# 97.0-r0:
+# - CVE-2021-4140
+# - CVE-2022-0511
+# - CVE-2022-22736
+# - CVE-2022-22737
+# - CVE-2022-22738
+# - CVE-2022-22739
+# - CVE-2022-22740
+# - CVE-2022-22741
+# - CVE-2022-22742
+# - CVE-2022-22743
+# - CVE-2022-22744
+# - CVE-2022-22745
+# - CVE-2022-22746
+# - CVE-2022-22747
+# - CVE-2022-22748
+# - CVE-2022-22749
+# - CVE-2022-22750
+# - CVE-2022-22751
+# - CVE-2022-22752
+# - CVE-2022-22753
+# - CVE-2022-22754
+# - CVE-2022-22755
+# - CVE-2022-22756
+# - CVE-2022-22757
+# - CVE-2022-22758
+# - CVE-2022-22759
+# - CVE-2022-22760
+# - CVE-2022-22761
+# - CVE-2022-22762
+# - CVE-2022-22764
+# 95.0-r0:
+# - CVE-2021-43536
+# - CVE-2021-43537
+# - CVE-2021-43538
+# - CVE-2021-43539
+# - CVE-2021-43540
+# - CVE-2021-43541
+# - CVE-2021-43542
+# - CVE-2021-43543
+# - CVE-2021-43544
+# - CVE-2021-43545
+# - CVE-2021-43546
+# 94.0-r0:
+# - CVE-2021-38503
+# - CVE-2021-38504
+# - CVE-2021-38505
+# - CVE-2021-38506
+# - CVE-2021-38507
+# - CVE-2021-38508
+# - CVE-2021-38509
+# - CVE-2021-38510
+# 93.0-r0:
+# - CVE-2021-32810
+# - CVE-2021-38496
+# - CVE-2021-38497
+# - CVE-2021-38498
+# - CVE-2021-38499
+# - CVE-2021-38500
+# - CVE-2021-38501
+# 92.0.1-r0:
+# - CVE-2021-29980
+# - CVE-2021-29981
+# - CVE-2021-29982
+# - CVE-2021-29983
+# - CVE-2021-29984
+# - CVE-2021-29985
+# - CVE-2021-29986
+# - CVE-2021-29987
+# - CVE-2021-29988
+# - CVE-2021-29989
+# - CVE-2021-29990
+# - CVE-2021-29991
+# - CVE-2021-29993
+# - CVE-2021-38491
+# - CVE-2021-38492
+# - CVE-2021-38493
+# - CVE-2021-38494
# 90.0-r0:
# - CVE-2021-29970
# - CVE-2021-29972
@@ -323,158 +519,263 @@ prepare() {
default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
+ export CFLAGS="${CFLAGS/-fstack-clash-protection/} -g0 -O2"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection/} -g0 -O2 -Wno-deprecated-builtins -Wno-deprecated-declarations"
+
_clear_vendor_checksums audio_thread_priority
- _clear_vendor_checksums target-lexicon-0.9.0
+
+ base64 -d "$srcdir"/mozilla-location.keys > "$builddir"/mozilla-api-key
+
+ cat > base-mozconfig <<-EOF
+ # disable unwanted things
+ ac_add_options --disable-bootstrap
+ ac_add_options --disable-cargo-incremental
+ ac_add_options --disable-debug
+ ac_add_options --disable-debug-symbols
+ ac_add_options --disable-install-strip
+ ac_add_options --disable-jemalloc
+ ac_add_options --disable-strip
+ ac_add_options --disable-tests
+ ac_add_options --disable-updater
+
+ # features
+ ac_add_options --enable-alsa
+ ac_add_options --enable-dbus
+ ac_add_options --enable-default-toolkit=cairo-gtk3-wayland
+ ac_add_options --enable-ffmpeg
+ ac_add_options --enable-hardening
+ ac_add_options --enable-linker=lld
+ ac_add_options --enable-necko-wifi
+ ac_add_options --enable-official-branding
+ ac_add_options --enable-optimize="$CFLAGS"
+ ac_add_options --enable-pulseaudio
+ ac_add_options --enable-release
+ ac_add_options --enable-update-channel=release
+
+ # system libs
+ ac_add_options --enable-system-pixman
+ ac_add_options --with-system-ffi
+ ac_add_options --with-system-icu
+ ac_add_options --with-system-jpeg
+ ac_add_options --with-system-libevent
+ ac_add_options --with-system-libvpx
+ ac_add_options --with-system-nspr
+ ac_add_options --with-system-nss
+ ac_add_options --with-system-png
+ ac_add_options --with-system-webp
+ ac_add_options --with-system-zlib
+
+ # misc
+ ac_add_options --allow-addon-sideload
+ ac_add_options --prefix=/usr
+ ac_add_options --with-distribution-id=org.alpinelinux
+ ac_add_options --with-libclang-path=/usr/lib
+ ac_add_options --with-unsigned-addon-scopes=app,system
+ ac_add_options --with-wasi-sysroot=/usr/share/wasi-sysroot
+ ac_add_options --host=$CHOST
+ ac_add_options --target=$CTARGET
+
+ # objdir
+ mk_add_options MOZ_OBJDIR="$builddir/obj"
+
+ mk_add_options RUSTFLAGS="$RUSTFLAGS"
+
+ # keys
+ # these are for alpine linux use only
+ ac_add_options --with-mozilla-api-keyfile="$builddir/mozilla-api-key"
+ EOF
+
+ case "$CARCH" in
+ x86|armv7)
+ # x86: https://github.com/rust-lang/libc/issues/3476
+ # armv7: error: unknown type name 'fpregset_t'
+ echo "ac_add_options --disable-crashreporter" >> base-mozconfig
+ ;;
+ esac
}
build() {
- mkdir -p "$builddir"/objdir
- cd "$builddir"/objdir
+ export MOZ_BUILD_DATE="$(date ${SOURCE_DATE_EPOCH:+ -d@${SOURCE_DATE_EPOCH}} "+%Y%m%d%H%M%S")"
+
+ # for lto
+ ulimit -n 4096
+
+ # can't be set here and fail
+ unset RUSTFLAGS
+
+ local thinlto_jobs=${JOBS:-1}
+ local link_threads=${JOBS:-1}
+
+ case "$CARCH" in
+ # on this platform, lld seems to not utilise >1 threads for thinlto for some reason.
+ # at the same time, having more than 8 also crashes lld for firefox buildsystems (why?).
+ aarch64)
+ if [ $thinlto_jobs -gt 8 ]; then
+ thinlto_jobs=8
+ fi
+ ;;
+ esac
+
+ case "$CARCH" in
+ arm*|x86)
+ link_threads=1
+ ;;
+ esac
+
+ export LDFLAGS="$LDFLAGS -Wl,--thinlto-jobs=$thinlto_jobs -Wl,--threads=$link_threads"
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
- export MACH_USE_SYSTEM_PYTHON=1
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
+ export MOZ_APP_REMOTINGNAME=firefox
+ export MOZBUILD_STATE_PATH="$srcdir"/mozbuild
+ # disable desktop notifications
+ export MOZ_NOSPAM=1
# Find our triplet JSON
export RUST_TARGET="$CTARGET"
- # Build with Clang, takes less RAM
- export CC="clang"
- export CXX="clang++"
+
+ # has to be same version or older than lld
+ export CC="clang-$_llvmver"
+ export CXX="clang++-$_llvmver"
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
- case "$CARCH" in
- arm*|x86*)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- ;;
- esac
+ # let firefox do this itself.
+ unset CARGO_PROFILE_RELEASE_OPT_LEVEL
+ unset CARGO_PROFILE_RELEASE_LTO
- # FF doesn't have SIMD available on these arches.
case "$CARCH" in
- armhf|armv7)
- _rust_simd="--disable-rust-simd"
- _low_mem_flags="--disable-debug-symbols --disable-debug"
- export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
- ;;
- x86)
- _low_mem_flags="--disable-debug-symbols --disable-debug"
- export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
- ;;
- *) _rust_simd="--enable-rust-simd" ;;
- esac
+ aarch64|x86_64|ppc64le)
+ msg "building instrumented firefox"
+ cat > .mozconfig base-mozconfig - <<-EOF
+ ac_add_options --enable-profile-generate=cross
+ EOF
+ ./mach build
+ ./mach package
- ../mach configure \
- --prefix=/usr \
- $_arch_config \
- $_low_mem_flags \
- $_rust_simd \
- \
- --disable-crashreporter \
- --disable-gold \
- --disable-install-strip \
- --disable-jemalloc \
- --disable-profiling \
- --disable-strip \
- --disable-tests \
- --disable-updater \
- \
- --enable-alsa \
- --enable-dbus \
- --enable-default-toolkit=cairo-gtk3-wayland \
- --enable-ffmpeg \
- --enable-hardening \
- --enable-necko-wifi \
- --enable-official-branding \
- --enable-optimize="$CFLAGS -O2" \
- --enable-pulseaudio \
- --disable-smoosh \
- --enable-system-ffi \
- --enable-system-pixman \
- \
- --with-system-ffi \
- --with-system-icu \
- --with-system-jpeg \
- --with-system-libevent \
- --with-system-libvpx \
- --with-system-nspr \
- --with-system-nss \
- --with-system-pixman \
- --with-system-png \
- --with-system-webp \
- --with-system-zlib \
- --with-clang-path=/usr/bin/clang \
- --with-libclang-path=/usr/lib
- ../mach build
-}
+ msg "profiling firefox"
-package() {
- cd "$builddir"/objdir
+ LLVM_PROFDATA=llvm-profdata \
+ JARLOG_FILE="$PWD"/jarlog \
+ GDK_BACKEND=x11 \
+ LD_LIBRARY_PATH="$PWD"/obj/dist/firefox \
+ XDG_RUNTIME_DIR="$(mktemp -d "$builddir/pgo-runtime-XXXXXX")" \
+ MOZ_ENABLE_WAYLAND=0 \
+ xvfb-run -a -s "-screen 0 1920x1080x24 -nolisten local" \
+ dbus-run-session -- \
+ ./mach python build/pgo/profileserver.py
- DESTDIR="$pkgdir" MOZ_MAKE_FLAGS="$MAKEOPTS" ../mach install
+ test -s merged.profdata
+ test -s jarlog
- install -m755 -d "$pkgdir"/usr/share/applications
- install -m755 -d "$pkgdir"/usr/share/pixmaps
+ ./mach clobber
+
+ msg "building optimised firefox"
+ cat > .mozconfig base-mozconfig - <<-EOF
+ ac_add_options --enable-lto=cross
+ ac_add_options --enable-profile-use=cross
+ ac_add_options --with-pgo-profile-path="$PWD"/merged.profdata
+ ac_add_options --with-pgo-jarlog="$PWD"/jarlog
+ EOF
+ ./mach build
+ ;;
+ armv7|x86|riscv64)
+ # others: no pgo here as it uses too much memory/broken on riscv
+ msg "building regular firefox"
+ cat > .mozconfig base-mozconfig - <<-EOF
+ ac_add_options --disable-profiling
+ EOF
+ ./mach build
+ ;;
+ *)
+ msg "implement build for $CARCH"
+ exit 1
+ esac
+}
+
+package() {
+ DESTDIR="$pkgdir" ./mach install
local _png
- for _png in ../browser/branding/official/default*.png; do
+ for _png in ./browser/branding/official/default*.png; do
local i=${_png%.png}
i=${i##*/default}
- install -D -m644 "$_png" "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox.png
+ install -d "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/
+ ln -s "$_mozappdir"/browser/chrome/icons/default/default"$i".png \
+ "$pkgdir"/usr/share/icons/hicolor/"$i"x"$i"/apps/firefox.png
done
- install -m644 "$builddir"/browser/branding/official/default48.png \
- "$pkgdir"/usr/share/pixmaps/firefox.png
- install -m644 "$srcdir"/firefox.desktop "$pkgdir"/usr/share/applications/org.mozilla.firefox.desktop
- install -m644 "$srcdir"/firefox-safe.desktop "$pkgdir"/usr/share/applications/org.mozilla.firefox-safe.desktop
-
- # Add StartupWMClass=firefox on the .desktop files so Desktop Environments
- # correctly associate the window with their icon, the correct fix is to have
- # firefox sets its own AppID but this will work for the meantime
- # See: https://bugzilla.mozilla.org/show_bug.cgi?id=1607399
- echo "StartupWMClass=firefox" >> "$pkgdir"/usr/share/applications/org.mozilla.firefox.desktop
- echo "StartupWMClass=firefox" >> "$pkgdir"/usr/share/applications/org.mozilla.firefox-safe.desktop
+ case "$CARCH" in
+ x86|arm*) ;;
+ *) patchelf --add-needed libscudo.so "$pkgdir"/usr/lib/firefox/firefox ;;
+ esac
- # install our vendor prefs
- install -d "$pkgdir"/$_mozappdir/browser/defaults/preferences
+ install -Dm644 browser/branding/official/content/about-logo.png \
+ "$pkgdir"/usr/share/icons/hicolor/192x192/apps/$pkgname.png
+ install -Dm644 browser/branding/official/content/about-logo@2x.png \
+ "$pkgdir"/usr/share/icons/hicolor/384x384/apps/$pkgname.png
+ install -Dm644 browser/branding/official/content/about-logo.svg \
+ "$pkgdir"/usr/share/icons/hicolor/scalable/apps/$pkgname.svg
- cat >> "$pkgdir"/$_mozappdir/browser/defaults/preferences/firefox-branding.js <<- EOF
- // Use LANG environment variable to choose locale
- pref("intl.locale.requested", "");
+ install -Dm644 "$srcdir"/firefox.desktop \
+ "$pkgdir"/usr/share/applications/firefox.desktop
- // Disable default browser checking.
- pref("browser.shell.checkDefaultBrowser", false);
+ install -Dm644 "$srcdir"/distribution.ini \
+ "$pkgdir"/$_mozappdir/distribution/distribution.ini
- // Don't disable our bundled extensions in the application directory
- pref("extensions.autoDisableScopes", 11);
- pref("extensions.shownSelectionUI", true);
- EOF
+ # install our vendor prefs
+ install -Dm644 "$srcdir"/vendor-prefs.js \
+ "$pkgdir"/$_mozappdir/browser/defaults/preferences/vendor.js
# Generate appdata file
- mkdir "$pkgdir"/usr/share/metainfo/
+ mkdir -p "$pkgdir"/usr/share/metainfo/
export VERSION="$pkgver"
export DATE="$_releasedate"
- cat "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in | envsubst > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox.appdata.xml
+ envsubst < "$builddir"/taskcluster/docker/firefox-flatpak/org.mozilla.firefox.appdata.xml.in > "$pkgdir"/usr/share/metainfo/org.mozilla.firefox.appdata.xml
+
+ # Replace duplicate binary with wrapper
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ install -Dm755 /dev/stdin "$pkgdir"/usr/bin/firefox <<- EOF
+ #!/bin/sh
+ exec $_mozappdir/firefox "\$@"
+ EOF
+ rm "$pkgdir"/$_mozappdir/firefox-bin
+ ln -sfv /usr/bin/firefox "$pkgdir"/$_mozappdir/firefox-bin
+}
+
+intl() {
+ pkgdesc="$pkgname - International ICU data"
+ depends="icu-data-full"
+ install_if="$pkgname=$pkgver-r$pkgrel icu"
+ mkdir -p "$subpkgdir"
}
sha512sums="
-4fda0b1e666fb0b1d846708fad2b48a5b53d48e7fc2a5da1f234b5b839c55265b41f6509e6b506d5e8a7455f816dfa5ab538589bc9e83b7e3846f0f72210513e firefox-90.0.2.source.tar.xz
-0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
-2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
-4510fb92653d0fdcfbc6d30e18087c0d22d4acd5eb53be7d0a333abe087a9e0bf9e58e56bafe96e1e1b28ebd1fd33b8926dbb70c221007e335b33d1468755c66 fix-tools.patch
-a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12c5e2ee30a09310159230524655a419a4f7e4eeeb0f3c06b0 mallinfo.patch
-454ea3263cabce099accbdc47aaf83be26a19f8b5a4568c01a7ef0384601cf8315efd86cd917f9c8bf419c2c845db89a905f3ff9a8eb0c8e41042e93aa96a85c disable-moz-stackwalk.patch
+282c45e5c468419536dd8b81c8ea687b10d8002d7521403330e6eeef49207143bee88a44c3785748d461ed9a72687606f5da14f4dfb98eb40a5cd08a4a12722b firefox-124.0.1.tar.xz
+0f7b741ea2fd492bc50256f3fcbd46c09e92211ad7a943474de99729245eddd063e4eca16a8e9a2d6919bfcfc81b739c6aa7b3463469608ebd4cb1e24d26abc1 crash-reporting-ptrace.patch
+eb49b791280a8d765e6b056816ad6d7ec20a3b13723ebe648a8ecd2c086a5bc83277a3b4c127a470e7bb7105cfa4ed7611c19ac683545140190cafaa880ad515 disable-moz-stackwalk.patch
+19eea840aa9c1c21e7bd1f832ec078989fe6f08fca40baa271be7e74f1cffeb5ab8d3218a93e664b8d90a41506dede524e2a5174cd47580866109bc6711ea969 fix-fortify-system-wrappers.patch
cd68b89e29e5f6379fbd5679db27b9a5ef70ea65e51c0d0a8137e1f1fd210e35a8cfb047798e9549bc7275606d7ec5c8d8af1335d29da4699db7acd8bc7ff556 fix-rust-target.patch
-47c2c2428c3598a42f6241705179642b3378a86ace39c8c3cbef4954e6d220b42e6c76f3d71731d65f67ce2c8597259122ac44bbd45e20993bb8bc70c0c8a010 fix-webrtc-glibcisms.patch
-60845dcb034b2c4459c30f7d5f25c8176cf42df794e2cc0e86c3e2abb6541c24b962f3a16ca70a288d4d6f377b68d00b2904b22463108559612053d835d9bff1 fd6847c9416f9eebde636e21d794d25d1be8791d.patch
-4e584621145cf8add069c6dac18e805b3274a1ee402d84e924df2341f7d3c5be261a93ef51283bacbd606f47fbdc628c4323ecc31efc5b403b8d224b18dc278f allow-custom-rust-vendor.patch
-f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
-5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop
-55eab1a02e19a19a1ee0e36b11097ab48a44200e07e543d91469967206854f39709c7c0bc31855559528e64642d610868140e9533f1c0e3bebc953353c142fa8 disable-neon-in-aom.patch
+305c874fdea3096e9c4c6aa6520ac64bb1c347c4b59db8360096646593fe684c3b5377874d91cecd33d56d1410b4714fbdea2b514923723ecbeff79d51265d9b fix-webrtc-glibcisms.patch
+b7a2beef126569d71242198f2503bb6a32acd1ea89080ef7bed6ba0f0d10819282c2c346c6f729d81cd90e328e607b88acaac8785ed057cc8cb562e315890334 force-can-use-pack-relative-relocs.patch
+afabea91b328c5a68eaa20f9099ac7b2d0e7f2423e816b05ed168bdd326a5684fa02de08bf05c6033e9b888f02775d1b0443a00329b7a632ee399122a391c13a icu74.patch
+5fa9382c692e4bd6a2634308f24a6526fd12a60a2563d2090056d43a60505df3ec9881bbf54562e69394467529b3b0dc45955afca46ed329af03cea074fff070 lfs64.patch
+c0437a6753f3f350968fa12d250efdfe1bea77baf0e4c06b072b5cc9e78c774dbf4506bc536337030d349fb3ba4460097b75b0c7c5b8fb2d39d8b0a392948936 no-ccache-stats.patch
+2d8dff86212d6d2a904cbb5a5a1d6c17b89adc929fc6a3f4c6cb669f5e83ecddff5a799225319ba445a187b04d111251af75dd3ce8a039164bc14d2a432a2a04 ppc-musttail.patch
+4de65266f5fc1c5bf1d7cd00a0e4728a1ec96b7680b5ea72d6e9ed463b7a0bba11792b3411d25ef1e26f62408eb7f8b06dc62209dbb0454c779d8858d8d59725 python-deps.patch
+f635243e587b5be2c82e96d8ad11e93f99e3130765e4b9e329ff7424f685d8f7bf385de66ca2698084e95da422d55192053a45412e75915423b327f2415f581d res_nquery.patch
+1c6918dd6655d3a1251bfd4af2e1c561cbb00d540a883b4c1ebf7f5de530d754d9ac07b4b5f56cdab6c511d25c8910ec94043f5733e97501a67abffe1bafaeb1 rust-lto-thin.patch
+b12dbff6513ac8c231d91c257a9accecc034d9ea9c31d99ca0454334ccf80fe7b50d6a356182dc46a9f25064366ea9a177f463cb2544b1cf5368ee6bd71bc095 riscv64-no-lto.patch
2518f2fc75b5db30058e0735f47d60fdf1e7adfaeee4b33fb2afb1bd9a616ce943fd88f4404d0802d4083703f4acf1d5ad42377218d025bc768807fbaf7e1609 sandbox-fork.patch
-db26757b2ebf9f567962e32294b4ae48b3a5d0378a7589dfe650fe3a179ff58befbab5082981c68e1c25fb9e56b2db1e4e510d4bca17c3e3aedbf9a2f21806eb sandbox-sched_setscheduler.patch
b7d0a6126bdf6c0569f80aabf5b37ed2c7a35712eb8a0404a2d85381552f5555d4f97d213ea26cec6a45dc2785f22439376ed5f8e78b4fd664ef0223307b333e sandbox-largefile.patch
-b1cb2db3122634f66d2bae7066e76f2dcd455c464e021db4de3b0a08314df95cb667846081682db549dd2af8a00831cabe44a2420c66cdfb5e3b5fa7e6bd21d3 avoid-redefinition.patch
+f8c3555ef6207933cbffbf4fc101a9b4c0d2990c0063162f0f0bde70ef0b46f86bfac42e7110695183424a87948de593f3927b2d8509ede3e4fc7bd8a1fad1ce sandbox-sched_setscheduler.patch
+67bc0be3da973e6859256bf9be4df7100837430e6076fc0bd623f504c35e02e6c191e9c5a3a1d202e5ad4d89f874f254a09e164e39c7bfd97bbc8d4c8d0632a5 sqlite-ppc.patch
+0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+333b9df0c8a7693601245dac13522c9e90632f490b2fe1b852bf85fbd033c111a82fec3cfc302cfdea62d591c51042ae69c2c33a5668afacca11ea1f215188bc firefox.desktop
+9869ef092609af4caed6aa27f3de6ac49b91ef993ccbfd8a2080465def442d3b02745fbe3c71d362f07c3075d46f388a023c0ad8ebb5f6ffd37e601d997b74f7 distribution.ini
+382510375b1a2fa79be0ab79e3391a021ae2c022429ffbaa7e7a69166f99bb56d01e59a1b10688592a29238f21c9d6977672bd77f9fae439b66bdfe0c55ddb15 mozilla-location.keys
+0423804a3c7c075de128b624110c58994ec8e10819fc09b74fdb4cd5aa6c0365cdafc77770af42f4ce856ad2e8e325a918344c57fb015a680b7e54555b94c6ed vendor-prefs.js
"