aboutsummaryrefslogtreecommitdiffstats
path: root/community/fisher/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fisher/APKBUILD')
-rw-r--r--community/fisher/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/fisher/APKBUILD b/community/fisher/APKBUILD
index 13cad917e45..37f3fc6582d 100644
--- a/community/fisher/APKBUILD
+++ b/community/fisher/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=fisher
pkgver=1.0.0
-pkgrel=0
+pkgrel=3
pkgdesc="Simple yet powerful webhooks catcher"
url="https://github.com/pietroalbini/fisher"
arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
license="GPL-3.0-or-later"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
install="$pkgname.pre-install"
subpackages="$pkgname-openrc"
source="https://github.com/pietroalbini/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz
@@ -17,16 +17,20 @@ source="https://github.com/pietroalbini/$pkgname/archive/v$pkgver/$pkgname-$pkgv
$pkgname.initd
$pkgname.logrotate
"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check" # problems with test dependencies
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
build() {
- cargo build --release --locked
+ cargo auditable build --frozen --release
}
package() {
- cd "$builddir"
-
install -m 755 -D target/release/fisher "$pkgdir"/usr/bin/fisher
install -m 644 -D config-example.toml "$pkgdir"/etc/fisher/config.toml