aboutsummaryrefslogtreecommitdiffstats
path: root/community/flarectl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/flarectl/APKBUILD')
-rw-r--r--community/flarectl/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/flarectl/APKBUILD b/community/flarectl/APKBUILD
new file mode 100644
index 00000000000..289c28c4c99
--- /dev/null
+++ b/community/flarectl/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=flarectl
+pkgver=0.92.0
+pkgrel=1
+pkgdesc="CLI application for interacting with a Cloudflare account"
+url="https://github.com/cloudflare/cloudflare-go/tree/master/cmd/flarectl"
+arch="all"
+license="BSD-3-Clause"
+makedepends="go"
+source="https://github.com/cloudflare/cloudflare-go/archive/refs/tags/v$pkgver/flarectl-$pkgver.tar.gz"
+builddir="$srcdir/cloudflare-go-$pkgver/cmd/flarectl"
+options="!check chmod-clean net" # no testsuite provided
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+export GOFLAGS="$GOFLAGS -buildvcs=false"
+
+build() {
+ go build -o flarectl
+}
+
+package() {
+ install -Dm755 flarectl -t "$pkgdir"/usr/bin
+}
+
+sha512sums="
+c55ed8bf29f9dd133c8ce487c5d42f3f0b2afff238edaccb003f9971ec677d5956430ae3a3ad810d9be35f38264a6c50a83483c8cf7ac40da82172604619f130 flarectl-0.92.0.tar.gz
+"