aboutsummaryrefslogtreecommitdiffstats
path: root/community/flickcurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/flickcurl/APKBUILD')
-rw-r--r--community/flickcurl/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/community/flickcurl/APKBUILD b/community/flickcurl/APKBUILD
index 66a411ba2db..53ac730f4ba 100644
--- a/community/flickcurl/APKBUILD
+++ b/community/flickcurl/APKBUILD
@@ -1,37 +1,34 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=flickcurl
pkgver=1.26
-pkgrel=2
+pkgrel=5
pkgdesc="C library for the Flickr API"
-url="http://librdf.org/flickcurl/"
+url="https://librdf.org/flickcurl/"
arch="all"
license="GPL-2.0"
makedepends="curl-dev libxml2-dev raptor2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://download.dajobe.org/flickcurl/flickcurl-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://download.dajobe.org/flickcurl/flickcurl-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
update_config_guess
update_config_sub
default_prepare
}
build() {
- cd "$builddir"
./configure --prefix /usr
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="5ffdef58e67cbf99da2e8eefad57e845627703d5b22c85d5635557cd2df53e47e74d8e3387523495708c5cc8952c290da5c4d5f1e86bd482312fc7e46e9af6cd flickcurl-1.26.tar.gz"
+sha512sums="
+5ffdef58e67cbf99da2e8eefad57e845627703d5b22c85d5635557cd2df53e47e74d8e3387523495708c5cc8952c290da5c4d5f1e86bd482312fc7e46e9af6cd flickcurl-1.26.tar.gz
+"