aboutsummaryrefslogtreecommitdiffstats
path: root/community/fluidsynth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fluidsynth/APKBUILD')
-rw-r--r--community/fluidsynth/APKBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/community/fluidsynth/APKBUILD b/community/fluidsynth/APKBUILD
index 9f02a033a76..403ce5a36e1 100644
--- a/community/fluidsynth/APKBUILD
+++ b/community/fluidsynth/APKBUILD
@@ -1,47 +1,55 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Dominika Liberda <ja@sdomi.pl>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fluidsynth
-pkgver=2.2.4
+pkgver=2.3.5
pkgrel=0
arch="all"
url="https://www.fluidsynth.org/"
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
license="LGPL-2.1-or-later"
-depends_dev="
+depends="soundfont-timgm"
+makedepends="
alsa-lib-dev
+ cmake
dbus-dev
+ doxygen
glib-dev
+ graphviz
jack-dev
+ ladspa-dev
libsndfile-dev
+ pipewire-dev
+ portaudio-dev
pulseaudio-dev
readline-dev
- "
-makedepends="$depends_dev
- cmake
- doxygen
- graphviz
+ samurai
"
source="https://github.com/fluidsynth/fluidsynth/archive/v$pkgver/fluidsynth-v$pkgver.tar.gz"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
# tests are broken on s390x
case "$CARCH" in
- s390x|mips64) options="!check"
+ s390x) options="!check"
esac
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ # need to set gnu_source globally to fix implicit decls
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
- -DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth
+ -DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth \
+ -Denable-ladspa=ON \
+ -Denable-portaudio=ON
cmake --build build
}
check() {
# ctest can't currently be used https://github.com/FluidSynth/fluidsynth/issues/881
- make -C build check
+ ninja -C build check
}
package() {
@@ -49,5 +57,5 @@ package() {
}
sha512sums="
-46c3f0759cc011f34e5ba80684df4e8b593315d564da2341aaea14a5f0ba9cf732933f6ebc8712506f194b044a8e2b198b9e50879ff4221e6a9ab8051e79b48f fluidsynth-v2.2.4.tar.gz
+35eaea8c1709ebbd5dee8f3946ab59c39afe31d92b972a44013fa23987aa48936f7d1326d5bda81c6e66f02bf988e48601367d49276a4dd78dbca7a2571f5e57 fluidsynth-v2.3.5.tar.gz
"