aboutsummaryrefslogtreecommitdiffstats
path: root/community/fluidsynth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fluidsynth/APKBUILD')
-rw-r--r--community/fluidsynth/APKBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/community/fluidsynth/APKBUILD b/community/fluidsynth/APKBUILD
index 2e8bdb710cd..3fd10de9cd4 100644
--- a/community/fluidsynth/APKBUILD
+++ b/community/fluidsynth/APKBUILD
@@ -1,47 +1,55 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Dominika Liberda <ja@sdomi.pl>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fluidsynth
-pkgver=2.2.3
+pkgver=2.3.4
pkgrel=0
arch="all"
url="https://www.fluidsynth.org/"
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
license="LGPL-2.1-or-later"
-depends_dev="
+depends="soundfont-timgm"
+makedepends="
alsa-lib-dev
+ cmake
dbus-dev
+ doxygen
glib-dev
+ graphviz
jack-dev
+ ladspa-dev
libsndfile-dev
+ pipewire-dev
+ portaudio-dev
pulseaudio-dev
readline-dev
- "
-makedepends="$depends_dev
- cmake
- doxygen
- graphviz
+ samurai
"
source="https://github.com/fluidsynth/fluidsynth/archive/v$pkgver/fluidsynth-v$pkgver.tar.gz"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
# tests are broken on s390x
case "$CARCH" in
- s390x|mips64) options="!check"
+ s390x) options="!check"
esac
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ # need to set gnu_source globally to fix implicit decls
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
- -DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth
+ -DFLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth \
+ -Denable-ladspa=ON \
+ -Denable-portaudio=ON
cmake --build build
}
check() {
# ctest can't currently be used https://github.com/FluidSynth/fluidsynth/issues/881
- make -C build check
+ ninja -C build check
}
package() {
@@ -49,5 +57,5 @@ package() {
}
sha512sums="
-67f8da02714350cc0439fbdce763d00cb08d01301a6aaa3e2655e67935048b43e18968c9a52aa64c702b5e30ae2b2b4946f69e8be4af5889fa414c654d4eb13e fluidsynth-v2.2.3.tar.gz
+79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0 fluidsynth-v2.3.4.tar.gz
"