aboutsummaryrefslogtreecommitdiffstats
path: root/community/fluidsynth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fluidsynth/APKBUILD')
-rw-r--r--community/fluidsynth/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/fluidsynth/APKBUILD b/community/fluidsynth/APKBUILD
index c1e5a0ac144..403ce5a36e1 100644
--- a/community/fluidsynth/APKBUILD
+++ b/community/fluidsynth/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Dominika Liberda <ja@sdomi.pl>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fluidsynth
-pkgver=2.2.7
+pkgver=2.3.5
pkgrel=0
arch="all"
url="https://www.fluidsynth.org/"
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
license="LGPL-2.1-or-later"
+depends="soundfont-timgm"
makedepends="
alsa-lib-dev
cmake
@@ -17,12 +19,14 @@ makedepends="
jack-dev
ladspa-dev
libsndfile-dev
+ pipewire-dev
portaudio-dev
pulseaudio-dev
readline-dev
+ samurai
"
source="https://github.com/fluidsynth/fluidsynth/archive/v$pkgver/fluidsynth-v$pkgver.tar.gz"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc"
# tests are broken on s390x
case "$CARCH" in
@@ -30,7 +34,9 @@ case "$CARCH" in
esac
build() {
- cmake -B build \
+ # need to set gnu_source globally to fix implicit decls
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
@@ -43,7 +49,7 @@ build() {
check() {
# ctest can't currently be used https://github.com/FluidSynth/fluidsynth/issues/881
- make -C build -k check
+ ninja -C build check
}
package() {
@@ -51,5 +57,5 @@ package() {
}
sha512sums="
-62709f96fa07bbafb9b907438da7376abdf1a4e679cd2b105c5bca257f1ff62c18bd4c646ef2ccba64ca5273604da996fb2caaf61eeee44686bf45fef1ed83a7 fluidsynth-v2.2.7.tar.gz
+35eaea8c1709ebbd5dee8f3946ab59c39afe31d92b972a44013fa23987aa48936f7d1326d5bda81c6e66f02bf988e48601367d49276a4dd78dbca7a2571f5e57 fluidsynth-v2.3.5.tar.gz
"