aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-hack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-hack/APKBUILD')
-rw-r--r--community/font-hack/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/font-hack/APKBUILD b/community/font-hack/APKBUILD
new file mode 100644
index 00000000000..837482ae9d7
--- /dev/null
+++ b/community/font-hack/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: mio <miyopan@e.email>
+pkgname=font-hack
+pkgver=3.003
+pkgrel=5
+pkgdesc="A typeface designed for source code"
+url="https://sourcefoundry.org/hack/"
+arch="noarch"
+license="MIT"
+depends="fontconfig mkfontscale"
+source="https://github.com/source-foundry/Hack/releases/download/v$pkgver/Hack-v$pkgver-ttf.tar.xz"
+builddir="$srcdir"
+options="!check" # is a font
+
+# backwards compat
+provides="ttf-hack=$pkgver-r$pkgrel"
+replaces="ttf-hack"
+
+package() {
+ install -D -m644 ./*.ttf -t "$pkgdir"/usr/share/fonts/hack
+}
+
+sha512sums="
+d6480957ef77b0e117a564b76e7b8b041a28cfc89441d394a27e2a1b230cae7a67c0b9f3cbe6aab48c5d2cc832b0ea653017a3b925db1d0cc2885e02eab9a81d Hack-v3.003-ttf.tar.xz
+"