aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-iosevka/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-iosevka/APKBUILD')
-rw-r--r--community/font-iosevka/APKBUILD81
1 files changed, 81 insertions, 0 deletions
diff --git a/community/font-iosevka/APKBUILD b/community/font-iosevka/APKBUILD
new file mode 100644
index 00000000000..a7154540f9a
--- /dev/null
+++ b/community/font-iosevka/APKBUILD
@@ -0,0 +1,81 @@
+# Contributor: psykose <alice@ayaya.dev>
+# Maintainer: psykose <alice@ayaya.dev>
+
+pkgname=font-iosevka
+pkgver=11.1.0
+pkgrel=0
+pkgdesc="Versatile typeface for code, from code."
+url="https://typeof.net/Iosevka/"
+arch="noarch"
+options="!check" # no testsuite
+license="OFL-1.1"
+depends="fontconfig"
+subpackages="
+ $pkgname-base
+ $pkgname-slab
+ $pkgname-curly
+ $pkgname-curly-slab
+ $pkgname-aile
+ $pkgname-etoile
+ "
+source="
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-$pkgver.zip
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-slab-$pkgver.zip
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-curly-$pkgver.zip
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-curly-slab-$pkgver.zip
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-aile-$pkgver.zip
+ https://github.com/be5invis/Iosevka/releases/download/v$pkgver/super-ttc-iosevka-etoile-$pkgver.zip
+ "
+
+builddir="$srcdir"
+
+_install_font_ttc() {
+ font="$srcdir/$1.ttc"
+ install -Dm644 "$font" -t "$subpkgdir"/usr/share/fonts/TTC
+}
+
+package() {
+ for pkg in $subpackages; do
+ depends="$depends $pkg"
+ done
+ mkdir -p "$pkgdir"
+}
+
+base() {
+ pkgdesc="$pkgdesc (Iosevka)"
+ _install_font_ttc "iosevka"
+}
+
+slab() {
+ pkgdesc="$pkgdesc (Iosevka Slab)"
+ _install_font_ttc "iosevka-slab"
+}
+
+curly() {
+ pkgdesc="$pkgdesc (Iosevka Curly)"
+ _install_font_ttc "iosevka-curly"
+}
+
+curly_slab() {
+ pkgdesc="$pkgdesc (Iosevka Curly Slab)"
+ _install_font_ttc "iosevka-curly-slab"
+}
+
+aile() {
+ pkgdesc="$pkgdesc (Iosevka Aile)"
+ _install_font_ttc "iosevka-aile"
+}
+
+etoile() {
+ pkgdesc="$pkgdesc (Iosevka Etoile)"
+ _install_font_ttc "iosevka-etoile"
+}
+
+sha512sums="
+30945211bf2a45606f9ab04587aad43c37ab46abc760b6c3a598600cb23cc2836da9ebf8968c8e57aa1769102e3ee95551422e1f8469aa57b4a5ff43e3762a10 super-ttc-iosevka-11.1.0.zip
+4aa59149ead69441c7ac52c6b6160c436d08873681c3b3eaad6ef18834b6eaec0ffd6da242d44c19f51800cd8c9b29dd375a348bbb69ebb96c507339b7652f4f super-ttc-iosevka-slab-11.1.0.zip
+7591d71e257ca0b7c907bb8d57a69602b82d82139324a7002e556f354b7b7ed6df0a3ea076b55fca5ef45dc4b21efb772ed70e27cb9c1097d6ca96224bba9aad super-ttc-iosevka-curly-11.1.0.zip
+af2bd3b770cf315e94949b5a5c500e081edc8aa536ea2e7240279f6b21d7574207f6a63a4995965b71138bbceb403cc2a7ed8230e756d76c6296cfe560d5ea35 super-ttc-iosevka-curly-slab-11.1.0.zip
+b5a9f8adc44d8b06d0b5334812acab637123f811a77c87077eba2c196936b6be862c3e3a7e80d4860b19409d2e228e3116a07a5f4a825cae08058a2e65b888d3 super-ttc-iosevka-aile-11.1.0.zip
+b114c6690fbbde121d03e3ba2a4ffba6075aa961b5e6f8f341d36cb7ffe5c647266e46f00d86be71b3a25477a22519699b36508da2db5101a4c97e7d0e39019a super-ttc-iosevka-etoile-11.1.0.zip
+"