aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-noto-cjk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-noto-cjk/APKBUILD')
-rw-r--r--community/font-noto-cjk/APKBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/community/font-noto-cjk/APKBUILD b/community/font-noto-cjk/APKBUILD
index a9ba0bfa426..c091e7b38ed 100644
--- a/community/font-noto-cjk/APKBUILD
+++ b/community/font-noto-cjk/APKBUILD
@@ -1,33 +1,46 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=font-noto-cjk
-pkgver=0_git20181130
-_sha=9326451d9b4f32ec7f8640581c5053cc192039f2
+pkgver=0_git20220127
+# actual tagged release, but stuff is kinda funny here, so keep naming it 'git'
+_rev=Sans2.004
pkgrel=1
pkgdesc="Google's font family that aims to support all the world's languages (cjk)"
-url="https://github.com/googlei18n/noto-fonts/"
+url="https://github.com/notofonts/noto-fonts"
arch="noarch"
license="OFL-1.1"
depends="fontconfig"
-options="!check"
subpackages="$pkgname-extra:_extra"
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-cjk/archive/$_sha.tar.gz"
-builddir="$srcdir/noto-cjk-$_sha"
+source="https://dev.alpinelinux.org/archive/font-noto-cjk/$pkgname-$pkgver.tar.xz"
+options="!check" # font
+
+# the git repo tarballs don't give any fonts (?),
+# and the releases have the wrong files
+snapshot() {
+ clean
+ makedepends="tar git xz" deps
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ git clone --depth=1 -b $_rev https://github.com/notofonts/noto-cjk .
+ mkdir -p $pkgname-$pkgver
+ cp ./*/OTC/*.ttc $pkgname-$pkgver/
+
+ tar cf $pkgname-$pkgver.tar $pkgname-$pkgver
+ xz -e -vv -9 -T0 $pkgname-$pkgver.tar
+}
package() {
- mkdir -p "$pkgdir"/usr/share/fonts/noto
for font in NotoSansCJK-Bold.ttc \
NotoSansCJK-Regular.ttc \
NotoSerifCJK-Bold.ttc \
NotoSerifCJK-Regular.ttc
do
- install -m644 "$builddir"/"$font" \
- "$pkgdir"/usr/share/fonts/noto/"$font"
+ install -Dm644 ./$font \
+ -t "$pkgdir"/usr/share/fonts/noto/
done
}
_extra() {
- mkdir -p "$subpkgdir"/usr/share/fonts/noto
for font in NotoSansCJK-Black.ttc \
NotoSansCJK-DemiLight.ttc \
NotoSansCJK-Light.ttc \
@@ -39,9 +52,11 @@ _extra() {
NotoSerifCJK-Medium.ttc \
NotoSerifCJK-SemiBold.ttc
do
- install -m644 "$builddir"/"$font" \
- "$subpkgdir"/usr/share/fonts/noto/"$font"
+ install -Dm644 "$builddir"/$font \
+ -t "$subpkgdir"/usr/share/fonts/noto/
done
}
-sha512sums="d4578421919d03ecf82627375cfc4b227825af485140b35e2315d17f8ef38d034e0ffdd21fb3aa226c82e9cf587123867d565f93d32f8bf7d754571f0ebf825e font-noto-cjk-0_git20181130.tar.gz"
+sha512sums="
+ee98197dcd2c2eb0a42e6057d5269fe33ab18d3ead2062956364af4c5a4886d9cd8293439c3c8b1983a9166119fb4ab710c16dac63ff571e6a4752315935c4b1 font-noto-cjk-0_git20220127.tar.xz
+"