aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-noto-emoji/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-noto-emoji/APKBUILD')
-rw-r--r--community/font-noto-emoji/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/community/font-noto-emoji/APKBUILD b/community/font-noto-emoji/APKBUILD
index a2df98cd873..355916c955f 100644
--- a/community/font-noto-emoji/APKBUILD
+++ b/community/font-noto-emoji/APKBUILD
@@ -1,41 +1,26 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=font-noto-emoji
-pkgver=2.034
+pkgver=2.042
pkgrel=0
pkgdesc="Google Noto emoji fonts"
url="https://github.com/googlefonts/noto-emoji"
arch="noarch"
license="OFL-1.1"
-makedepends="
- bash
- cairo-dev
- imagemagick
- libpng-dev
- nototools
- optipng
- pngquant
- py3-fonttools
- py3-setuptools
- python3
- zopfli
- "
source="https://github.com/googlefonts/noto-emoji/archive/v$pkgver/font-noto-emoji-$pkgver.tar.gz"
options="!check" # No code to test
builddir="$srcdir/noto-emoji-$pkgver"
-build() {
- make VIRTUAL_ENV=False BYPASS_SEQUENCE_CHECK=True
-}
+# Prior to commit 213931dec8bb08b1d4e500bf06f3892d711e9499 we build
+# font-noto-emoji from source. However, some makedependencies were not
+# available on all architectures and building everything from source
+# blocks some builders for some time, hence using the pre-built now.
package() {
- # Fonts in the fonts/ subdirectory are pre-built.
- # TODO: Figure out if we can build NotoEmoji-Regular.ttf too somehow
install -Dm644 -t "$pkgdir"/usr/share/fonts/noto \
- NotoColorEmoji.ttf \
- fonts/NotoEmoji-Regular.ttf
+ fonts/NotoColorEmoji.ttf
}
sha512sums="
-a7ea0c33f4703749d8a30f4be2fac5971429dcec7b6feed2645854d9ae1eebb428597a56ad148c3732e320a65d4133da30c0003ed39f07c5270462e31fdf3d0b font-noto-emoji-2.034.tar.gz
+50a5fab34788e091269ae3085bb69f8a45c44a4cd31f67cf6b3143f8f0a73186e13a6607770999ab27a1a8edaeeb308092e994d50c0a009d4c375eaa22e0b160 font-noto-emoji-2.042.tar.gz
"