aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-noto-emoji/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-noto-emoji/APKBUILD')
-rw-r--r--community/font-noto-emoji/APKBUILD39
1 files changed, 10 insertions, 29 deletions
diff --git a/community/font-noto-emoji/APKBUILD b/community/font-noto-emoji/APKBUILD
index 49f5052a556..355916c955f 100644
--- a/community/font-noto-emoji/APKBUILD
+++ b/community/font-noto-emoji/APKBUILD
@@ -1,45 +1,26 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=font-noto-emoji
-pkgver=0_git20211101
-# The tag isn't random but based on the upstream tags
-# We don't use the tags directly as it uses a strange naming scheme
-_commit="9a5261d871451f9b5183c93483cbd68ed916b1e9"
+pkgver=2.042
pkgrel=0
pkgdesc="Google Noto emoji fonts"
url="https://github.com/googlefonts/noto-emoji"
-arch="noarch !mips !mips64" # fails to build on mips
+arch="noarch"
license="OFL-1.1"
-makedepends="
- bash
- cairo-dev
- imagemagick
- libpng-dev
- nototools
- optipng
- pngquant
- py3-fonttools
- py3-setuptools
- python3
- zopfli
- "
-source="https://github.com/googlefonts/noto-emoji/archive/$_commit/font-noto-emoji-$_commit.tar.gz
- "
+source="https://github.com/googlefonts/noto-emoji/archive/v$pkgver/font-noto-emoji-$pkgver.tar.gz"
options="!check" # No code to test
-builddir="$srcdir/noto-emoji-$_commit"
+builddir="$srcdir/noto-emoji-$pkgver"
-build() {
- make VIRTUAL_ENV=False BYPASS_SEQUENCE_CHECK=True
-}
+# Prior to commit 213931dec8bb08b1d4e500bf06f3892d711e9499 we build
+# font-noto-emoji from source. However, some makedependencies were not
+# available on all architectures and building everything from source
+# blocks some builders for some time, hence using the pre-built now.
package() {
- # Fonts in the fonts/ subdirectory are pre-built.
- # TODO: Figure out if we can build NotoEmoji-Regular.ttf too somehow
install -Dm644 -t "$pkgdir"/usr/share/fonts/noto \
- NotoColorEmoji.ttf \
- fonts/NotoEmoji-Regular.ttf
+ fonts/NotoColorEmoji.ttf
}
sha512sums="
-b80d3ca838e0cc66b6b6af9b368164da3f40bd22cfbb1d923a172bd51e87f1db9b7722494f220e4e912160664bb1c5318bbd9253981c1262ce563482d6cad7a4 font-noto-emoji-9a5261d871451f9b5183c93483cbd68ed916b1e9.tar.gz
+50a5fab34788e091269ae3085bb69f8a45c44a4cd31f67cf6b3143f8f0a73186e13a6607770999ab27a1a8edaeeb308092e994d50c0a009d4c375eaa22e0b160 font-noto-emoji-2.042.tar.gz
"