aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-noto-emoji/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/font-noto-emoji/APKBUILD')
-rw-r--r--community/font-noto-emoji/APKBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/community/font-noto-emoji/APKBUILD b/community/font-noto-emoji/APKBUILD
index 077dcd504c5..355916c955f 100644
--- a/community/font-noto-emoji/APKBUILD
+++ b/community/font-noto-emoji/APKBUILD
@@ -1,30 +1,26 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=font-noto-emoji
-pkgver=0_git20200916
-_commit="aac7ccaa4d1dea4543453b96f7d6fc47066a57ff"
+pkgver=2.042
pkgrel=0
pkgdesc="Google Noto emoji fonts"
url="https://github.com/googlefonts/noto-emoji"
-arch="noarch !mips !mips64" # fails to build on mips
+arch="noarch"
license="OFL-1.1"
-makedepends="optipng py3-fonttools cairo-dev imagemagick
- py3-setuptools bash nototools libpng-dev python3
- pngquant zopfli"
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-emoji/archive/$_commit.tar.gz"
+source="https://github.com/googlefonts/noto-emoji/archive/v$pkgver/font-noto-emoji-$pkgver.tar.gz"
options="!check" # No code to test
-builddir="$srcdir/noto-emoji-$_commit"
+builddir="$srcdir/noto-emoji-$pkgver"
-build() {
- make VIRTUAL_ENV=False BYPASS_SEQUENCE_CHECK=True
-}
+# Prior to commit 213931dec8bb08b1d4e500bf06f3892d711e9499 we build
+# font-noto-emoji from source. However, some makedependencies were not
+# available on all architectures and building everything from source
+# blocks some builders for some time, hence using the pre-built now.
package() {
- # Fonts in the fonts/ subdirectory are pre-built.
- # TODO: Figure out if we can build NotoEmoji-Regular.ttf too somehow
- mkdir -p "$pkgdir"/usr/share/fonts/noto
- install -m644 NotoColorEmoji.ttf fonts/NotoEmoji-Regular.ttf \
- "$pkgdir"/usr/share/fonts/noto
+ install -Dm644 -t "$pkgdir"/usr/share/fonts/noto \
+ fonts/NotoColorEmoji.ttf
}
-sha512sums="d497c4ecaf299ade23b1f6a3bc6e98d7dbbb619e51f067496d4a4dbf71693c96de26263af595c0aae86c63dcea8be190718f5477af645d4338989f25cc3ab848 font-noto-emoji-0_git20200916.tar.gz"
+sha512sums="
+50a5fab34788e091269ae3085bb69f8a45c44a4cd31f67cf6b3143f8f0a73186e13a6607770999ab27a1a8edaeeb308092e994d50c0a009d4c375eaa22e0b160 font-noto-emoji-2.042.tar.gz
+"