aboutsummaryrefslogtreecommitdiffstats
path: root/community/foot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/foot/APKBUILD')
-rw-r--r--community/foot/APKBUILD67
1 files changed, 48 insertions, 19 deletions
diff --git a/community/foot/APKBUILD b/community/foot/APKBUILD
index 8a86cbd14be..a5ef7234dd1 100644
--- a/community/foot/APKBUILD
+++ b/community/foot/APKBUILD
@@ -1,50 +1,79 @@
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=foot
-pkgver=1.9.2
+pkgver=1.17.2
pkgrel=0
-pkgdesc="A fast, lightweight and minimalistic Wayland terminal emulator"
-url="https://codeberg.org/dnkl/foot.git"
-arch="all"
+pkgdesc="Fast, lightweight and minimalistic Wayland terminal emulator"
+url="https://codeberg.org/dnkl/foot"
license="MIT"
+arch="all"
depends="ncurses-terminfo"
makedepends="
+ cage
+ font-dejavu
+ fcft-dev
+ fontconfig-dev
+ freetype-dev
+ libxkbcommon-dev
meson
+ ncurses
+ pixman-dev
scdoc
- fcft-dev
tllist-dev
- libxkbcommon-dev
+ utf8proc-dev
wayland-dev
- pixman-dev
- freetype-dev
- fontconfig-dev
wayland-protocols
- ncurses
- utf8proc-dev
"
subpackages="
+ $pkgname-dbg
$pkgname-doc
$pkgname-bash-completion
- $pkgname-zsh-completion
$pkgname-fish-completion
+ $pkgname-zsh-completion
+ $pkgname-extra-terminfo:_extra_terminfo:noarch
+ $pkgname-themes:_themes:noarch
+ "
+source="
+ $pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/foot/archive/$pkgver.tar.gz
"
-source="$pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/foot/archive/$pkgver.tar.gz"
-options="!check" # No tests
+options="!check" # ran during profiling
builddir="$srcdir/foot"
build() {
- export CFLAGS="$CFLAGS -O3" # -O3 as the package is intended to use it
+ export CFLAGS="$CFLAGS -O3" # -O3 as the package is intended to use it
+ export CXXFLAGS="$CXXFLAGS -O3"
+ export CPPFLAGS="$CPPFLAGS -O3"
+
abuild-meson \
- -Dterminfo=disabled \
+ -Db_pgo=generate \
+ -Db_lto=true \
+ -Dterminfo-base-name=foot-extra \
+ -Dutmp-backend=none \
. output
meson compile -C output
+
+ ninja -C output test
+ ./pgo/full-headless-cage.sh . output
+
+ meson configure -Db_pgo=use output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
- install -Dm644 foot.ini "$pkgdir"/usr/share/foot/foot.ini
- mv "$pkgdir"/usr/share/fish/vendor_completions.d "$pkgdir"/usr/share/fish/completions
+}
+
+_extra_terminfo() {
+ pkgdesc="$pkgdesc (extra terminfo data)"
+
+ amove /usr/share/terminfo/f
+}
+
+_themes() {
+ pkgdesc="$pkgdesc (color schemes)"
+
+ amove /usr/share/foot/themes
}
sha512sums="
-8b14443c7be64f333a46e9aa444e64b599c5e77b622545ebdad8162dc2b50c0fa0f7d48ff369b36ec792ba64ad321b82b887e4366b5a87efb475dc64b4b98c43 foot-1.9.2.tar.gz
+72a9fc5ec38c2cb8417b74c3089c82d7a0c0090339ab2312df3d1eafc442e5254ae79f9dcfefa50d8866e77a5776aa6fc5727a758f792986abf0cfb9b4f0658e foot-1.17.2.tar.gz
"