aboutsummaryrefslogtreecommitdiffstats
path: root/community/fractal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fractal/APKBUILD')
-rw-r--r--community/fractal/APKBUILD48
1 files changed, 37 insertions, 11 deletions
diff --git a/community/fractal/APKBUILD b/community/fractal/APKBUILD
index 925555d379f..22b8f516645 100644
--- a/community/fractal/APKBUILD
+++ b/community/fractal/APKBUILD
@@ -1,19 +1,42 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fractal
-pkgver=4.4.0
-pkgrel=2
+pkgver=6
+pkgrel=0
pkgdesc="Matrix group messaging app"
url="https://wiki.gnome.org/Apps/Fractal"
-arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by Rust
+arch="x86_64 aarch64 ppc64le" # limited by Rust + crate dependencies
license="GPL-3.0-or-later"
-depends="dbus:org.freedesktop.Secrets xdg-utils"
-makedepends="meson gtk+3.0-dev dbus-dev openssl1.1-compat-dev gspell-dev libhandy-dev
- gtksourceview4-dev gstreamer-dev gst-plugins-base-dev gst-plugins-bad-dev
- gst-editing-services-dev glib-dev cargo gmp-dev gst-plugins-good-gtk"
+depends="
+ dbus:org.freedesktop.Secrets
+ gst-plugins-good-gtk
+ xdg-utils
+ "
+makedepends="
+ cargo
+ clang-libclang
+ cmake
+ dbus-dev
+ desktop-file-utils
+ glib-dev
+ gmp-dev
+ gspell-dev
+ gst-editing-services-dev
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ gtksourceview5-dev
+ libadwaita-dev
+ libshumate-dev
+ meson
+ openssl-dev
+ pipewire-dev
+ xdg-desktop-portal-dev
+ "
options="!check" # no tests
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/GNOME/fractal/-/archive/$pkgver/fractal-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.gnome.org/GNOME/fractal/-/archive/$pkgver/fractal-$pkgver.tar.gz"
case "$CARCH" in
x86)
@@ -21,13 +44,16 @@ case "$CARCH" in
;;
esac
+
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="0dfc363ad7f152976e224bdab52b469f8277b214cf47180611a26622ea9e370477c947ace62fe0a6b275e79416b0288c7d021ca3afb387277810a9a26433d6ef fractal-4.4.0.tar.gz"
+sha512sums="
+4a57aedba9cd6e79999457837d2932ddbe5b62a2cb7d22dc8afd15c509c30484a663697cec91c2f5b40ab5153aadb0fac65a3d2ce59f444ff6ffe1f566d566ab fractal-6.tar.gz
+"