aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/frameworkintegration/APKBUILD')
-rw-r--r--community/frameworkintegration/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 9b18a625125..b81ed69d7dd 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=frameworkintegration
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
# armhf blocked by extra-cmake-modules
@@ -18,15 +21,16 @@ depends_dev="
knotifications-dev
kpackage-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/frameworkintegration.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -37,8 +41,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +49,5 @@ package() {
}
sha512sums="
-5b6a4f562183c4cda5c068786b14db22508af0ea535cf6a03e5502834196a6393a43def590fea1ee8562cb7f3bbc2c69722d459225b0128a593f32ba486a5e51 frameworkintegration-5.97.0.tar.xz
+2f16528997b54ebb95e2fde1fe94133d672e72ef91bb2e607887b733fef128ea9c3e57b1f3f8cbf0ba74835dab6e145729725746918eaac98b643446a0cb3391 frameworkintegration-6.1.0.tar.xz
"