aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/frameworkintegration/APKBUILD')
-rw-r--r--community/frameworkintegration/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 2364389b798..b81ed69d7dd 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=frameworkintegration
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
@@ -19,26 +21,27 @@ depends_dev="
knotifications-dev
kpackage-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/frameworkintegration.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +49,5 @@ package() {
}
sha512sums="
-eb226600a1c17ebb9387eb42b212b6d2397f118ce2c52ba2463e8c8acf62b39f96aafe68573b9474bf4c0a13d6542bcadcb35ff4c8880425d448838630ea179f frameworkintegration-5.84.0.tar.xz
+2f16528997b54ebb95e2fde1fe94133d672e72ef91bb2e607887b733fef128ea9c3e57b1f3f8cbf0ba74835dab6e145729725746918eaac98b643446a0cb3391 frameworkintegration-6.1.0.tar.xz
"