aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/frameworkintegration/APKBUILD')
-rw-r--r--community/frameworkintegration/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index febf7b9602c..b81ed69d7dd 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=frameworkintegration
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
@@ -19,15 +21,16 @@ depends_dev="
knotifications-dev
kpackage-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/frameworkintegration.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -38,8 +41,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-a6fbc2bdeac9a3e2aecf0b6e2bfa0169b36e02d03665758230abc2497015a1540d33e58cb0283ec8333713debb58289deb423a679f726e041ada2d325833d743 frameworkintegration-5.95.0.tar.xz
+2f16528997b54ebb95e2fde1fe94133d672e72ef91bb2e607887b733fef128ea9c3e57b1f3f8cbf0ba74835dab6e145729725746918eaac98b643446a0cb3391 frameworkintegration-6.1.0.tar.xz
"