aboutsummaryrefslogtreecommitdiffstats
path: root/community/frameworkintegration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/frameworkintegration/APKBUILD')
-rw-r--r--community/frameworkintegration/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 0c7a874fa56..a2bce6067b9 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=frameworkintegration
-pkgver=5.90.0
-pkgrel=1
+pkgver=6.0.0
+pkgrel=0
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
@@ -19,28 +21,27 @@ depends_dev="
knotifications-dev
kpackage-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz
- 0001-Fix-wrong-porting-of-KNSCore-Engine-configSearchLocations.patch
- "
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/frameworks/frameworkintegration.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/frameworkintegration-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -48,6 +49,5 @@ package() {
}
sha512sums="
-4f27d8aa453ab5d08e410db4c93bd86386159bb3e82a65cff0c4264ec3467f916a761e7cc0f68365c3f821cce8c84ff6277afb975a967fe26ed7a545155defca frameworkintegration-5.90.0.tar.xz
-2e5abc183359fa8246dbc146b3726726db59a8c5665ba59d0e647fda8bbdd53f7f5ba483f0ebcaef42eb7e506ee5f886ee58169a5d946da3f0c6614522ce632b 0001-Fix-wrong-porting-of-KNSCore-Engine-configSearchLocations.patch
+565c26aa54b45e872deb28aeba3660423c1f57e488690896571cd8d5ae8c6a74e99c71588d314d36874b1a2275e9b78178815772c404d27c0abaaeba0f74638f frameworkintegration-6.0.0.tar.xz
"