aboutsummaryrefslogtreecommitdiffstats
path: root/community/fs-uae-launcher/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fs-uae-launcher/APKBUILD')
-rw-r--r--community/fs-uae-launcher/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/fs-uae-launcher/APKBUILD b/community/fs-uae-launcher/APKBUILD
new file mode 100644
index 00000000000..601b5061652
--- /dev/null
+++ b/community/fs-uae-launcher/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=fs-uae-launcher
+pkgver=3.1.68
+pkgrel=4
+pkgdesc="FS-UAE emulator launcher."
+url="https://github.com/FrodeSolheim/fs-uae-launcher"
+arch="noarch !armhf !armv7 !aarch64 !s390x" # fs-uae not avail
+license="GPL-2.0-only"
+depends="
+ fs-uae
+ py3-lhafile
+ py3-pyqt5-sip
+ py3-qt5
+ py3-requests
+ py3-setuptools
+ python3
+ "
+makedepends="gettext"
+subpackages="$pkgname-lang $pkgname-pyc"
+source="https://fs-uae.net/files/FS-UAE-Launcher/Stable/$pkgver/fs-uae-launcher-$pkgver.tar.xz"
+options="!check" # no testsuite
+
+package() {
+ python3 setup.py install \
+ --root="$pkgdir" \
+ --install-lib=/usr/share/fs-uae-launcher \
+ --install-scripts=/usr/share/fs-uae-launcher
+
+ make DESTDIR="$pkgdir" prefix=/usr install-data
+
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s ../share/fs-uae-launcher/fs-uae-launcher "$pkgdir"/usr/bin/fs-uae-launcher
+ rm -rf "$pkgdir"/usr/share/doc
+}
+
+pyc() {
+ default_pyc
+
+ local IFS=$'\n'
+ amove $(find usr/share/fs-uae-launcher -type d -name __pycache__)
+}
+
+sha512sums="
+a637117602c7276b60350ac3bb9c69eec4c18454efd4024e7b822da897eee0f9299f406e4126771f753b75f29d53591e9bbe3e4cbc016dda1ec063e73fe51f07 fs-uae-launcher-3.1.68.tar.xz
+"