aboutsummaryrefslogtreecommitdiffstats
path: root/community/fs-uae-launcher/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fs-uae-launcher/APKBUILD')
-rw-r--r--community/fs-uae-launcher/APKBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/community/fs-uae-launcher/APKBUILD b/community/fs-uae-launcher/APKBUILD
index d2f7c8d353a..601b5061652 100644
--- a/community/fs-uae-launcher/APKBUILD
+++ b/community/fs-uae-launcher/APKBUILD
@@ -1,14 +1,22 @@
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=fs-uae-launcher
pkgver=3.1.68
-pkgrel=0
+pkgrel=4
pkgdesc="FS-UAE emulator launcher."
url="https://github.com/FrodeSolheim/fs-uae-launcher"
arch="noarch !armhf !armv7 !aarch64 !s390x" # fs-uae not avail
license="GPL-2.0-only"
-depends="fs-uae py3-qt5 py3-pyqt5-sip"
-makedepends="py3-setuptools gettext"
-subpackages="$pkgname-lang"
+depends="
+ fs-uae
+ py3-lhafile
+ py3-pyqt5-sip
+ py3-qt5
+ py3-requests
+ py3-setuptools
+ python3
+ "
+makedepends="gettext"
+subpackages="$pkgname-lang $pkgname-pyc"
source="https://fs-uae.net/files/FS-UAE-Launcher/Stable/$pkgver/fs-uae-launcher-$pkgver.tar.xz"
options="!check" # no testsuite
@@ -25,6 +33,13 @@ package() {
rm -rf "$pkgdir"/usr/share/doc
}
+pyc() {
+ default_pyc
+
+ local IFS=$'\n'
+ amove $(find usr/share/fs-uae-launcher -type d -name __pycache__)
+}
+
sha512sums="
a637117602c7276b60350ac3bb9c69eec4c18454efd4024e7b822da897eee0f9299f406e4126771f753b75f29d53591e9bbe3e4cbc016dda1ec063e73fe51f07 fs-uae-launcher-3.1.68.tar.xz
"