aboutsummaryrefslogtreecommitdiffstats
path: root/community/fuse-exfat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fuse-exfat/APKBUILD')
-rw-r--r--community/fuse-exfat/APKBUILD42
1 files changed, 27 insertions, 15 deletions
diff --git a/community/fuse-exfat/APKBUILD b/community/fuse-exfat/APKBUILD
index ec9973125b0..d06eacb4fbe 100644
--- a/community/fuse-exfat/APKBUILD
+++ b/community/fuse-exfat/APKBUILD
@@ -1,25 +1,25 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse-exfat
-_pkgreal=exfat
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Free exFAT file system implementation"
url="https://github.com/relan/exfat"
arch="all"
license="GPL-2.0-or-later"
options="!check" # No test suite
-provides="$_pkgreal"
-makedepends="autoconf automake fuse-dev"
+provides="exfat"
+provider_priority=20
+makedepends="autoconf automake fuse3-dev"
subpackages="$pkgname-doc $pkgname-utils"
-source="$_pkgreal-$pkgver.tar.gz::https://github.com/relan/$_pkgreal/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/relan/exfat/archive/v$pkgver.tar.gz
0001-allow-command-line-argument-order-used-by-mount-8.patch
"
-builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/exfat-$pkgver"
prepare() {
default_prepare
- autoreconf --install
+ autoreconf -fvi
}
build() {
@@ -27,22 +27,34 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sbindir=/sbin
+ --sbindir=/usr/sbin
make
}
package() {
make DESTDIR="$pkgdir" install
+
+ # resove conflict with community/exfatprogs.
+ # while -utils provides the same binaries there is no need for
+ # the two packages two conflict if -utils is not installed.
+ mv "$pkgdir"/usr/share/man/man8/exfatlabel.8 \
+ "$pkgdir"/usr/share/man/man8/exfatlabel.exfat-fuse.8
}
utils() {
pkgdesc="$pkgdesc (utilities)"
- provides="$_pkgreal-utils"
- mkdir -p "$subpkgdir"/sbin
- local file; for file in $(find "$pkgdir"/sbin ! -name "mount*" -a ! -type d); do
- mv $file "$subpkgdir"/${file#$pkgdir}
+ # other provider is exfatprogs
+ provides="exfat-utils"
+ provider_priority=1
+ replaces="exfatprogs"
+
+ cd "$pkgdir"
+ local file; for file in $(find usr/sbin ! -name "mount*" -a ! -type d); do
+ amove $file
done
}
-sha512sums="fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8ae5e891c46195be53d2a10d62444e2fa1bb3fa3de59c2c3411c6dac363b488 exfat-1.3.0.tar.gz
-1c3d61310f6a2f7b126d57825f7eee7acde46f809bb2f1eb9857b35c831b9499a4d63c39a76c4d67f85e8541565e6dafb7321fbe0cbe4af6d4fa6eb9f1c00dd1 0001-allow-command-line-argument-order-used-by-mount-8.patch"
+sha512sums="
+70a951c878e3eb9173c8bc24908da1a64e4e83990b4ae3bb53a9f20e9d618f30ef7e93e818f0387fe9a76a87c8ba970aa2d8728c386865fe658d76c1bee830ae fuse-exfat-1.4.0.tar.gz
+1c3d61310f6a2f7b126d57825f7eee7acde46f809bb2f1eb9857b35c831b9499a4d63c39a76c4d67f85e8541565e6dafb7321fbe0cbe4af6d4fa6eb9f1c00dd1 0001-allow-command-line-argument-order-used-by-mount-8.patch
+"