aboutsummaryrefslogtreecommitdiffstats
path: root/community/fvwm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fvwm/APKBUILD')
-rw-r--r--community/fvwm/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/fvwm/APKBUILD b/community/fvwm/APKBUILD
new file mode 100644
index 00000000000..e0a5aeb460a
--- /dev/null
+++ b/community/fvwm/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=fvwm
+pkgver=2.6.6
+pkgrel=0
+pkgdesc="FVWM is a powerful desktop window manager for the X Window system"
+url="http://fvwm.org"
+arch="all"
+license="GPL2"
+depends=
+depends_dev="libxcursor-dev libx11-dev freetype-dev fontconfig-dev
+ gettext-dev libxft-dev libxt-dev libxext-dev libpng-dev libxpm-dev"
+makedepends="$depends_dev perl libxslt"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://github.com/fvwmorg/fvwm/releases/download/version-2_6_6/$pkgname-$pkgver.tar.gz"
+
+_builddir=$srcdir/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-perllib \
+ --disable-bidi \
+ --disable-rsvg \
+ --disable-xinerama \
+ --disable-gtk \
+ --with-gnome=no \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="76e8731bf02ba0b73cfbbf7628f2230f fvwm-2.6.6.tar.gz"
+sha256sums="c5de085ff25b2128a401a80225481e63335f815f84eea139f80a5f66e606dc2c fvwm-2.6.6.tar.gz"
+sha512sums="9a3b188fa052f1fc2ca593be323916d8d728f1f1633b02058f4cce96cebb3c98de2a179b73e1dd6fb65a4275329f54cd720fcc3ac05ef0ec7299b7bc7cbfc116 fvwm-2.6.6.tar.gz"