aboutsummaryrefslogtreecommitdiffstats
path: root/community/fwsnort/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fwsnort/APKBUILD')
-rw-r--r--community/fwsnort/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/community/fwsnort/APKBUILD b/community/fwsnort/APKBUILD
index 460c8f0c1aa..04971678a99 100644
--- a/community/fwsnort/APKBUILD
+++ b/community/fwsnort/APKBUILD
@@ -2,23 +2,20 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=fwsnort
pkgver=1.6.8
-pkgrel=2
+pkgrel=4
pkgdesc="Application layer IDS/IPS by translating snort rules into iptables"
url="http://www.cipherdyne.org/fwsnort/"
arch="noarch"
license="GPL"
-depends="perl perl-netaddr-ip perl-iptables-parse iptables ip6tables net-tools wget"
+depends="perl perl-netaddr-ip perl-iptables-parse iptables net-tools wget"
install="$pkgname.post-install"
options="checkroot"
source="http://www.cipherdyne.org/$pkgname/download/$pkgname-nodeps-$pkgver.tar.gz
fwsnort.up
fwsnort.update
periodic.daily"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
# Disable Root requirement to build.
local start=$(sed -n '/die "You need to be root (or equivalent UID 0"/=' ./install.pl)
local end=$(expr $start + 1)
@@ -38,8 +35,6 @@ build() {
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/etc "$pkgdir"/usr
cp -rf test/fwsnort-install/* "$pkgdir"/
cp -f fwsnort.conf "$pkgdir"/etc/fwsnort/fwsnort.conf