aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fzf/APKBUILD')
-rw-r--r--community/fzf/APKBUILD78
1 files changed, 55 insertions, 23 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
index 7b6f0526907..d1b828d6e09 100644
--- a/community/fzf/APKBUILD
+++ b/community/fzf/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=fzf
-pkgver=0.27.2
-pkgrel=2
+pkgver=0.49.0
+pkgrel=1
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
arch="all"
@@ -12,21 +12,25 @@ makedepends="go bash"
options="net chmod-clean"
subpackages="
$pkgname-tmux::noarch
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-bash-plugin:_bash:noarch
+ $pkgname-zsh-plugin:_zsh:noarch
+ $pkgname-fish-plugin:_fish:noarch
$pkgname-vim:vim:noarch
$pkgname-neovim:nvim:noarch
$pkgname-doc
"
+install="$pkgname.post-upgrade"
source="$pkgname-$pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$pkgver.tar.gz
- find-buzybox-compat.patch
- do-not-require-bash-by-default.patch
+ $pkgname.plugin.sh
+ $pkgname.plugin.zsh
"
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build
+ go build -ldflags "-X main.version=$pkgver -X main.revision=AlpineLinux"
}
check() {
@@ -53,34 +57,62 @@ tmux() {
install -Dm0755 bin/fzf-tmux "$subpkgdir"/usr/bin/fzf-tmux
}
-bashcomp() {
- pkgdesc="additional scripts for bash like shell completion and keybindings"
- depends=""
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+_bash() {
+ pkgdesc="Bash plugin for $pkgname (completion and key bindings)"
+ depends="perl"
+ install_if="$pkgname=$pkgver-r$pkgrel bash"
+ # For backward compatibility (Alpine <3.16).
+ replaces="$pkgname-bash-completion<0.29.0-r4"
cd "$builddir"
- install -Dm0644 shell/completion.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+
+ install -D -m644 shell/*.bash "$srcdir"/$pkgname.plugin.sh \
+ -t "$subpkgdir"/usr/share/bash/plugins/$pkgname/
+
+ # For backward compatibility (Alpine <3.16).
mkdir -p "$subpkgdir"/usr/share/fzf/
- install -m0644 shell/key-bindings.bash "$subpkgdir"/usr/share/fzf/
+ ln -s ../bash/plugins/$pkgname/key-bindings.bash "$subpkgdir"/usr/share/fzf/
}
-zshcomp() {
- pkgdesc="additional scripts for zsh like shell completion and keybindings"
+_zsh() {
+ pkgdesc="Zsh plugin for $pkgname (completion and key bindings)"
depends=""
install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ # For backward compatibility (Alpine <3.16).
+ replaces="$pkgname-zsh-completion<0.29.0-r4"
cd "$builddir"
- install -Dm0644 shell/completion.zsh \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+
+ install -D -m644 shell/*.zsh "$srcdir"/$pkgname.plugin.zsh \
+ -t "$subpkgdir"/usr/share/zsh/plugins/$pkgname/
+
+ # For backward compatibility (Alpine <3.16).
mkdir -p "$subpkgdir"/usr/share/fzf/
- install -m0644 shell/key-bindings.zsh "$subpkgdir"/usr/share/fzf/
+ ln -s ../zsh/plugins/$pkgname/key-bindings.zsh "$subpkgdir"/usr/share/fzf/
+}
+
+_fish() {
+ pkgdesc="Fish key bindings for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+ # For backward compatibility (Alpine <3.16).
+ replaces="$pkgname-fish-completion<0.29.0-r4"
+
+ cd "$builddir"
+ install -D -m644 shell/key-bindings.fish \
+ "$subpkgdir"/usr/share/fish/vendor_functions.d/$pkgname-key-bindings.fish
+
+ # For backward compatibility (Alpine <3.16).
+ mkdir -p "$subpkgdir"/usr/share/fzf/
+ ln -s ../fish/vendor_functions.d/$pkgname-key-bindings.fish "$subpkgdir"/usr/share/fzf/
}
vim() {
pkgdesc="fzf vim plugin"
install="$pkgname-vim.post-install"
install_if="$pkgname=$pkgver-r$pkgrel vim"
+ depends="vim"
+
cd "$builddir"
install -Dm0644 plugin/fzf.vim "$subpkgdir"/usr/share/vim/vimfiles/plugin/fzf.vim
install -Dm0644 doc/fzf.txt "$subpkgdir"/usr/share/vim/vimfiles/doc/fzf.txt
@@ -95,7 +127,7 @@ nvim() {
}
sha512sums="
-8ca27b61b6b2a66bdfd06dc8ad9e5163f3b69d64a44e1a99df5a2af35a63ccf7a9a77f9faed27fead373f5c212396327a3c0300b31f22583a35a1ae2aeac9865 fzf-0.27.2.tar.gz
-c59e7eb712f5072a2c66b79800f7674d1f9208b1ead4f654e57f8dcb673a45a751725a005c89759847f78c7ae7f246980b2c94e5fff5a3e8c2f6a364965e567e find-buzybox-compat.patch
-cdedfa6af278d243fb92e50d6a1929c2ac675beceef958cb2a464b3cc2c77a44883e96efd2c5a0606f3b840834bd38b53f98c9519e85b0d909f48bd872e378bc do-not-require-bash-by-default.patch
+fe9d380e1fba460a45ce70a3b44681454833243881a133108f9087a204b1adaafae7bc13e083d25bc783eedb7d4998d5f2301c87f981c0368d081f7f60107fe8 fzf-0.49.0.tar.gz
+a13ba25c08fe5b54231508be8d2f0a9f4d342630e6c31f2524cc6b8b99cead5b80daa2e2e37a581198f9ce79df2b00fdf81acf84fe1ad8043ee96e4db0870ee6 fzf.plugin.sh
+4ea4a5511704ef6fe57e7d3187739ba501ddb80d249738310d773edd9e2d08c26d27ec0c8976320e979aa8688984fe591b63a63b3c8589d5b80190e7d85d1c8b fzf.plugin.zsh
"