aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/fzf/APKBUILD')
-rw-r--r--community/fzf/APKBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
index 6fc93ba2138..d1b828d6e09 100644
--- a/community/fzf/APKBUILD
+++ b/community/fzf/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=fzf
-pkgver=0.32.0
-pkgrel=0
+pkgver=0.49.0
+pkgrel=1
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
arch="all"
@@ -21,18 +21,16 @@ subpackages="
"
install="$pkgname.post-upgrade"
source="$pkgname-$pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$pkgver.tar.gz
- find-buzybox-compat.patch
- do-not-require-bash-by-default.patch
$pkgname.plugin.sh
$pkgname.plugin.zsh
"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build
+ go build -ldflags "-X main.version=$pkgver -X main.revision=AlpineLinux"
}
check() {
@@ -61,7 +59,7 @@ tmux() {
_bash() {
pkgdesc="Bash plugin for $pkgname (completion and key bindings)"
- depends=""
+ depends="perl"
install_if="$pkgname=$pkgver-r$pkgrel bash"
# For backward compatibility (Alpine <3.16).
replaces="$pkgname-bash-completion<0.29.0-r4"
@@ -113,6 +111,8 @@ vim() {
pkgdesc="fzf vim plugin"
install="$pkgname-vim.post-install"
install_if="$pkgname=$pkgver-r$pkgrel vim"
+ depends="vim"
+
cd "$builddir"
install -Dm0644 plugin/fzf.vim "$subpkgdir"/usr/share/vim/vimfiles/plugin/fzf.vim
install -Dm0644 doc/fzf.txt "$subpkgdir"/usr/share/vim/vimfiles/doc/fzf.txt
@@ -127,9 +127,7 @@ nvim() {
}
sha512sums="
-2792e4b96ec41e0cd1e91e6e4276568502760bb07ef25d7193e70b46785438b1a42c7de936698f27fce9722d1c54f6e40c5b7f1f31bf140a4ff2ce1733cf14e0 fzf-0.32.0.tar.gz
-1617ba83064c3f41e716127f1c790dd624e4e4a2afc61949ccf6c652dda80ce59e4586b9eb8a4d9f85e039aa20248b26ff43661d7b7515d8b0bf2a7af2e7cd55 find-buzybox-compat.patch
-cdedfa6af278d243fb92e50d6a1929c2ac675beceef958cb2a464b3cc2c77a44883e96efd2c5a0606f3b840834bd38b53f98c9519e85b0d909f48bd872e378bc do-not-require-bash-by-default.patch
+fe9d380e1fba460a45ce70a3b44681454833243881a133108f9087a204b1adaafae7bc13e083d25bc783eedb7d4998d5f2301c87f981c0368d081f7f60107fe8 fzf-0.49.0.tar.gz
a13ba25c08fe5b54231508be8d2f0a9f4d342630e6c31f2524cc6b8b99cead5b80daa2e2e37a581198f9ce79df2b00fdf81acf84fe1ad8043ee96e4db0870ee6 fzf.plugin.sh
4ea4a5511704ef6fe57e7d3187739ba501ddb80d249738310d773edd9e2d08c26d27ec0c8976320e979aa8688984fe591b63a63b3c8589d5b80190e7d85d1c8b fzf.plugin.zsh
"