aboutsummaryrefslogtreecommitdiffstats
path: root/community/gbinder-python/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gbinder-python/APKBUILD')
-rw-r--r--community/gbinder-python/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/gbinder-python/APKBUILD b/community/gbinder-python/APKBUILD
new file mode 100644
index 00000000000..53fc1a44e5f
--- /dev/null
+++ b/community/gbinder-python/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=gbinder-python
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Python bindings for libgbinder"
+url="https://github.com/erfanoabdi/gbinder-python"
+# s390x blocked by libgbinder
+arch="all !s390x"
+license="GPL-3.0-only"
+depends="python3"
+makedepends="
+ cython
+ libgbinder-dev
+ py3-setuptools
+ python3-dev
+ "
+source="https://github.com/erfanoabdi/gbinder-python/archive/$pkgver/gbinder-python-$pkgver.tar.gz"
+options="!check" # No properly runnable tests
+
+build() {
+ python3 setup.py build --cython
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+6f076a5cb265eed193d2ac2623921e76ced923230ca2131460efea941182f26b770d657f5155f6a29fa54a314f6dc62a8d5b96d14ee90a359389e60318a38b71 gbinder-python-1.1.2.tar.gz
+"