aboutsummaryrefslogtreecommitdiffstats
path: root/community/gbinder-python/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gbinder-python/APKBUILD')
-rw-r--r--community/gbinder-python/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/gbinder-python/APKBUILD b/community/gbinder-python/APKBUILD
index b8162c3aaeb..53fc1a44e5f 100644
--- a/community/gbinder-python/APKBUILD
+++ b/community/gbinder-python/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=gbinder-python
-pkgver=0_git20210812
+pkgver=1.1.2
pkgrel=1
-_commit="2e1e05c0a0240d6c06e9bbe9b22dcc35c2e0211c"
pkgdesc="Python bindings for libgbinder"
url="https://github.com/erfanoabdi/gbinder-python"
# s390x blocked by libgbinder
@@ -16,18 +15,23 @@ makedepends="
py3-setuptools
python3-dev
"
-source="https://github.com/erfanoabdi/gbinder-python/archive/$_commit/gbinder-python-$_commit.tar.gz"
+source="https://github.com/erfanoabdi/gbinder-python/archive/$pkgver/gbinder-python-$pkgver.tar.gz"
options="!check" # No properly runnable tests
-builddir="$srcdir/$pkgname-$_commit"
build() {
python3 setup.py build --cython
}
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-f7b997e73424af0050485dba61f42aa14430a8ae44b868d1726913923e4967c41b0f4ebbb543662343fb912759c5a34d2d279414b505cc33b36253818c8ff36d gbinder-python-2e1e05c0a0240d6c06e9bbe9b22dcc35c2e0211c.tar.gz
+6f076a5cb265eed193d2ac2623921e76ced923230ca2131460efea941182f26b770d657f5155f6a29fa54a314f6dc62a8d5b96d14ee90a359389e60318a38b71 gbinder-python-1.1.2.tar.gz
"