aboutsummaryrefslogtreecommitdiffstats
path: root/community/gcc-avr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gcc-avr/APKBUILD')
-rw-r--r--community/gcc-avr/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/gcc-avr/APKBUILD b/community/gcc-avr/APKBUILD
index f2e7c408047..9b44ddd572a 100644
--- a/community/gcc-avr/APKBUILD
+++ b/community/gcc-avr/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=gcc-avr
-pkgver=11.2.0
-pkgrel=0
+pkgver=12.2.0
+pkgrel=4
pkgdesc="The GNU Compiler Collection for AVR targets"
url="https://gcc.gnu.org/"
depends="binutils-avr"
makedepends="bash linux-headers gmp-dev mpfr-dev mpc1-dev zlib-dev isl-dev"
-arch="all"
+arch="x86_64 aarch64 ppc64le x86"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
source="
@@ -23,8 +23,13 @@ build() {
mkdir "$_workingdir"
cd "$_workingdir"
- export CFLAGS_FOR_TARGET='-pipe'
- export CXXFLAGS_FOR_TARGET='-pipe'
+ export CFLAGS_FOR_TARGET='-pipe -Os -ffunction-sections -fdata-sections'
+ export CXXFLAGS_FOR_TARGET='-pipe -Os -ffunction-sections -fdata-sections -fno-use-cxa-atexit'
+
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100431
+ export CFLAGS="$CFLAGS -Wno-error=format-security"
+ export CXXFLAGS="$CXXFLAGS -Wno-error=format-security"
+ export CPPFLAGS="$CPPFLAGS -Wno-error=format-security"
"$builddir"/configure \
--target=avr \
@@ -35,7 +40,7 @@ build() {
--with-python-dir=share/gcc-avr \
--libexecdir=/usr/lib \
--enable-languages=c,c++ \
- --enable-__cxa_atexit \
+ --disable-__cxa_atexit \
--disable-install-libiberty \
--disable-libssp \
--disable-libstdcxx-pch \
@@ -61,6 +66,6 @@ package() {
}
sha512sums="
-d53a0a966230895c54f01aea38696f818817b505f1e2bfa65e508753fcd01b2aedb4a61434f41f3a2ddbbd9f41384b96153c684ded3f0fa97c82758d9de5c7cf gcc-11.2.0.tar.xz
+e9e857bd81bf7a370307d6848c81b2f5403db8c7b5207f54bce3f3faac3bde63445684092c2bc1a2427cddb6f7746496d9fbbef05fbbd77f2810b2998f1f9173 gcc-12.2.0.tar.xz
358cb41e6a8612f5c96f27ed573354a909253565caa200af8959d90cf21e0ddbee219f6281fc3917ead1f85c5ec7111162f9b075c3e478df56a2fad505bce5f1 fix-no-system-headers.patch
"