aboutsummaryrefslogtreecommitdiffstats
path: root/community/gcc-avr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gcc-avr/APKBUILD')
-rw-r--r--community/gcc-avr/APKBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/community/gcc-avr/APKBUILD b/community/gcc-avr/APKBUILD
index 767e6c287ef..6e89a3b6bfd 100644
--- a/community/gcc-avr/APKBUILD
+++ b/community/gcc-avr/APKBUILD
@@ -7,13 +7,14 @@ pkgrel=0
pkgdesc="The GNU Compiler Collection for AVR targets"
url="https://gcc.gnu.org/"
depends="binutils-avr"
-makedepends="bash linux-headers gmp-dev mpfr-dev mpc1-dev zlib-dev"
+makedepends="bash linux-headers gmp-dev mpfr-dev mpc1-dev zlib-dev isl-dev"
arch="all"
-license="GPL LGPL"
+license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
-_islver=0.18
-source="https://mirrors.kernel.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
+source="
+ https://mirrors.kernel.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
+ fix-no-system-headers.patch
+ "
builddir="$srcdir/gcc-$pkgver"
_workingdir="$builddir/build"
@@ -22,18 +23,18 @@ build() {
mkdir "$_workingdir"
cd "$_workingdir"
- # link isl for in-tree build
- ln -s "$srcdir"/isl-"$_islver" "$builddir"/isl
-
export CFLAGS_FOR_TARGET='-pipe'
export CXXFLAGS_FOR_TARGET='-pipe'
"$builddir"/configure \
- --build="$CBUILD" \
--target=avr \
--prefix=/usr \
+ --with-sysroot=/usr/avr \
+ --with-native-system-header-dir=/include \
+ --with-headers=/usr/avr/include \
+ --with-python-dir=share/gcc-avr \
+ --libexecdir=/usr/lib \
--enable-languages=c,c++ \
- --enable-ld=default \
--enable-__cxa_atexit \
--disable-install-libiberty \
--disable-libssp \
@@ -42,14 +43,12 @@ build() {
--disable-linker-build-id \
--disable-nls \
--disable-werror \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --with-as=/usr/bin/avr-as \
--with-gnu-as \
--with-gnu-ld \
- --with-ld=/usr/bin/avr-ld \
--with-system-zlib \
- --with-isl
+ --with-isl \
+ --with-avrlibc \
+ --with-pkgversion='Alpine Linux'
make
}
@@ -62,4 +61,4 @@ package() {
}
sha512sums="42ae38928bd2e8183af445da34220964eb690b675b1892bbeb7cd5bb62be499011ec9a93397dba5e2fb681afadfc6f2767d03b9035b44ba9be807187ae6dc65e gcc-10.2.0.tar.xz
-85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94 isl-0.18.tar.bz2"
+358cb41e6a8612f5c96f27ed573354a909253565caa200af8959d90cf21e0ddbee219f6281fc3917ead1f85c5ec7111162f9b075c3e478df56a2fad505bce5f1 fix-no-system-headers.patch"