aboutsummaryrefslogtreecommitdiffstats
path: root/community/geany-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geany-plugins/APKBUILD')
-rw-r--r--community/geany-plugins/APKBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/community/geany-plugins/APKBUILD b/community/geany-plugins/APKBUILD
index 63e65a803ee..686f029b1ea 100644
--- a/community/geany-plugins/APKBUILD
+++ b/community/geany-plugins/APKBUILD
@@ -1,14 +1,26 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geany-plugins
-pkgver=1.37
-pkgrel=1
+pkgver=1.38
+pkgrel=3
pkgdesc="Plugins for Geany"
url="https://plugins.geany.org/"
arch="all"
license="GPL-3.0-or-later"
-makedepends="lua-dev geany-dev enchant2-dev intltool gtkspell-dev libxml2-dev
- bash vte3-dev vala libsoup-dev gpgme-dev python3-dev"
+makedepends="
+ bash
+ enchant2-dev
+ geany-dev
+ gpgme-dev
+ gtkspell-dev
+ intltool
+ libsoup-dev
+ libxml2-dev
+ lua-dev
+ python3-dev
+ vala
+ vte3-dev
+ "
subpackages="$pkgname-dev $pkgname-doc
$pkgname-addons
$pkgname-autoclose
@@ -47,11 +59,11 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-keyrecord
$pkgname-utils
$pkgname-scope
-
$pkgname-lang
"
-
-source="https://plugins.geany.org/geany-plugins/geany-plugins-$pkgver.tar.bz2"
+source="https://plugins.geany.org/geany-plugins/geany-plugins-$pkgver.tar.bz2
+ int-conversion.patch
+ "
build() {
./configure --prefix=/usr \
@@ -137,4 +149,7 @@ xmlsnippets() { _plugin xmlsnippets "Extends XML/HTML tag autocompletion provide
keyrecord() { _plugin keyrecord "Record a sequence of keystrokes and replay it"; }
scope() { _plugin scope "Graphical GDB front-end"; }
-sha512sums="7757ab05bc557f04153a7e7d5f0e13857eed2fa625b13c17a4d5856341e64a50923ff797c31f13fd307c0e8081488876d80eaed7cb5ea57860c3b93ea06cbda2 geany-plugins-1.37.tar.bz2"
+sha512sums="
+360905c9b550266ee8cf05396a46465c3f6614709f413f1bc230a1a0f7e3274ae315f2df50ad1eb44550dd32a29d531d9da677b1ecf316dc48a492394de02461 geany-plugins-1.38.tar.bz2
+b256b7a4df31e33d5312d650fc04ca6d86cc6ce0e4da2ea56e5b82a98bf0825febc2ecfd6ae8a8548e69d2490820847a0b212cf00a2415b5603f2f04d44ac61d int-conversion.patch
+"