aboutsummaryrefslogtreecommitdiffstats
path: root/community/gemget/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gemget/APKBUILD')
-rw-r--r--community/gemget/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/gemget/APKBUILD b/community/gemget/APKBUILD
index 797f5399d5e..b7e49ddbbf2 100644
--- a/community/gemget/APKBUILD
+++ b/community/gemget/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: omni <omni@gitlab.alpinelinux.org>
# Maintainer: omni <omni@gitlab.alpinelinux.org>
pkgname=gemget
-pkgver=1.8.0
-pkgrel=5
+pkgver=1.9.0
+pkgrel=8
pkgdesc="command line downloader for the Gemini protocol"
url="https://github.com/makeworld-the-better-one/gemget"
license="MIT"
@@ -11,8 +11,10 @@ makedepends="go"
options="!check" # no test files
source="$pkgname-$pkgver.tar.gz::https://github.com/makeworld-the-better-one/gemget/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v .
@@ -22,4 +24,6 @@ package() {
install -Dm0755 "$pkgname" -t "$pkgdir"/usr/bin
}
-sha512sums="158a6519dc1c63e7398e85e56091deb433a2531b561470265346b9b07a7410b5517b0a082303c472c464fb166a01e803859cc0943426bafd99f894e5699291c3 gemget-1.8.0.tar.gz"
+sha512sums="
+2f433b29dd56adae25f5344b5cc2aeb2408921bfc374b5b55ea972670c8ae2d2e3913b6da92ed4ccb14efc2fbc116ccb656c0a2d8ccec314c235e21a10639f9e gemget-1.9.0.tar.gz
+"