aboutsummaryrefslogtreecommitdiffstats
path: root/community/gemget/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gemget/APKBUILD')
-rw-r--r--community/gemget/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/gemget/APKBUILD b/community/gemget/APKBUILD
new file mode 100644
index 00000000000..b7e49ddbbf2
--- /dev/null
+++ b/community/gemget/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: omni <omni@gitlab.alpinelinux.org>
+# Maintainer: omni <omni@gitlab.alpinelinux.org>
+pkgname=gemget
+pkgver=1.9.0
+pkgrel=8
+pkgdesc="command line downloader for the Gemini protocol"
+url="https://github.com/makeworld-the-better-one/gemget"
+license="MIT"
+arch="all"
+makedepends="go"
+options="!check" # no test files
+source="$pkgname-$pkgver.tar.gz::https://github.com/makeworld-the-better-one/gemget/archive/v$pkgver.tar.gz"
+
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ go build -v .
+}
+
+package() {
+ install -Dm0755 "$pkgname" -t "$pkgdir"/usr/bin
+}
+
+sha512sums="
+2f433b29dd56adae25f5344b5cc2aeb2408921bfc374b5b55ea972670c8ae2d2e3913b6da92ed4ccb14efc2fbc116ccb656c0a2d8ccec314c235e21a10639f9e gemget-1.9.0.tar.gz
+"