aboutsummaryrefslogtreecommitdiffstats
path: root/community/geoclue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geoclue/APKBUILD')
-rw-r--r--community/geoclue/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/geoclue/APKBUILD b/community/geoclue/APKBUILD
index 2dfdffbb18f..c64c85362be 100644
--- a/community/geoclue/APKBUILD
+++ b/community/geoclue/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geoclue
-pkgver=2.6.0
-pkgrel=0
+pkgver=2.7.1
+pkgrel=1
pkgdesc="dbus geolocation service"
url="https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home"
arch="all"
@@ -10,10 +10,9 @@ license="LGPL-2.1-or-later"
makedepends="
avahi-dev
gobject-introspection-dev
- intltool
json-glib-dev
libnotify-dev
- libsoup-dev
+ libsoup3-dev
meson
vala
"
@@ -21,6 +20,7 @@ subpackages="$pkgname-dev $pkgname-doc"
install="$pkgname.pre-install"
source="
https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/$pkgver/geoclue-$pkgver.tar.bz2
+ mozilla-location.keys
"
case "$CARCH" in
@@ -34,18 +34,23 @@ case "$CARCH" in
esac
build() {
+ # these keys are for alpine linux use only
+ local mozkey
+ mozkey="$(base64 -d "$srcdir"/mozilla-location.keys)"
abuild-meson \
+ -Db_lto=true \
-Ddbus-srv-user=geoclue \
-Ddbus-sys-dir=/usr/share/dbus-1/system.d \
-Dgtk-doc=false \
-Dintrospection=true \
+ -Dmozilla-api-key="$mozkey" \
$_arch_opts \
build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
@@ -53,5 +58,6 @@ package() {
}
sha512sums="
-13205ab88cbd9748c155081318ae1909fddedce4250e3ece39a9f379b8cfea91dfe571961e278406ba54f8efd3a1070967479feb8256f50170112b28246b3103 geoclue-2.6.0.tar.bz2
+972663a6f8c969d0e1a5f911af2b8afed486d5c0ba06dadc19bcfbe1ea22cef10243b2bd0084e5c45b70977cfa5650c8f15f760e4bc4e7dbd946745b67c9188b geoclue-2.7.1.tar.bz2
+382510375b1a2fa79be0ab79e3391a021ae2c022429ffbaa7e7a69166f99bb56d01e59a1b10688592a29238f21c9d6977672bd77f9fae439b66bdfe0c55ddb15 mozilla-location.keys
"