aboutsummaryrefslogtreecommitdiffstats
path: root/community/geoclue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geoclue/APKBUILD')
-rw-r--r--community/geoclue/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/geoclue/APKBUILD b/community/geoclue/APKBUILD
index 3924c2a806c..c64c85362be 100644
--- a/community/geoclue/APKBUILD
+++ b/community/geoclue/APKBUILD
@@ -1,50 +1,63 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geoclue
-pkgver=2.5.6
-pkgrel=2
+pkgver=2.7.1
+pkgrel=1
pkgdesc="dbus geolocation service"
-url="https://www.freedesktop.org/wiki/Software/GeoClue/"
+url="https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home"
arch="all"
license="LGPL-2.1-or-later"
makedepends="
- meson
- libsoup-dev
- json-glib-dev
avahi-dev
- intltool
gobject-introspection-dev
+ json-glib-dev
libnotify-dev
+ libsoup3-dev
+ meson
+ vala
"
subpackages="$pkgname-dev $pkgname-doc"
install="$pkgname.pre-install"
-source="https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/$pkgver/geoclue-$pkgver.tar.bz2"
+source="
+ https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/$pkgver/geoclue-$pkgver.tar.bz2
+ mozilla-location.keys
+ "
case "$CARCH" in
- s390x) _arch_opts="-D3g-source=false -Dcdma-source=false -Dmodem-gps-source=false"
+ s390x|riscv64)
+ _arch_opts="-D3g-source=false -Dcdma-source=false -Dmodem-gps-source=false"
;;
- *) _arch_opts=""
+ *)
+ _arch_opts=""
makedepends="$makedepends modemmanager-dev"
;;
esac
build() {
+ # these keys are for alpine linux use only
+ local mozkey
+ mozkey="$(base64 -d "$srcdir"/mozilla-location.keys)"
abuild-meson \
+ -Db_lto=true \
-Ddbus-srv-user=geoclue \
-Ddbus-sys-dir=/usr/share/dbus-1/system.d \
-Dgtk-doc=false \
-Dintrospection=true \
+ -Dmozilla-api-key="$mozkey" \
$_arch_opts \
build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C build
}
-sha512sums="d05160c95b80f05211d22de2631faf16d7263028c2eaf36a2cabf4d942e3db1d6157cd7feb7980ea358d208d5a24da181a3082488d9afcd126e2eecce5f4e78b geoclue-2.5.6.tar.bz2"
+sha512sums="
+972663a6f8c969d0e1a5f911af2b8afed486d5c0ba06dadc19bcfbe1ea22cef10243b2bd0084e5c45b70977cfa5650c8f15f760e4bc4e7dbd946745b67c9188b geoclue-2.7.1.tar.bz2
+382510375b1a2fa79be0ab79e3391a021ae2c022429ffbaa7e7a69166f99bb56d01e59a1b10688592a29238f21c9d6977672bd77f9fae439b66bdfe0c55ddb15 mozilla-location.keys
+"