aboutsummaryrefslogtreecommitdiffstats
path: root/community/geos/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geos/APKBUILD')
-rw-r--r--community/geos/APKBUILD50
1 files changed, 17 insertions, 33 deletions
diff --git a/community/geos/APKBUILD b/community/geos/APKBUILD
index e13c98480e8..5790d41c324 100644
--- a/community/geos/APKBUILD
+++ b/community/geos/APKBUILD
@@ -1,48 +1,32 @@
# Contributor: Eric Kidd <git@randomhacks.net>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=geos
-pkgver=3.9.1
+pkgver=3.12.1
pkgrel=0
pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
-url="https://trac.osgeo.org/geos/"
-arch="all !s390x !mips !mips64"
+url="https://libgeos.org/"
+arch="all"
license="LGPL-2.1-or-later"
-subpackages="
- $pkgname-dev
- "
-source="
- http://download.osgeo.org/geos/geos-$pkgver.tar.bz2
- "
+makedepends="cmake samurai"
+subpackages="$pkgname-dev"
+source="https://download.osgeo.org/geos/geos-$pkgver.tar.bz2"
build() {
- case "$CARCH" in
- aarch64*|ppc64le) CXXFLAGS="$CXXFLAGS -ffp-contract=off" ;;
- esac
-
- # fix build on armhf and armv7 with info from
- # https://trac.osgeo.org/geos/ticket/993
- local inline="--enable-inline"
- case "$CARCH" in
- armhf|armv7) inline="--disable-inline" ;;
- esac
-
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- $inline
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON
+ cmake --build build
}
check() {
- make check
+ ctest --test-dir build --output-on-failure -j${JOBS:-2}
}
package() {
- make DESTDIR="$pkgdir" install
- find $pkgdir -name "*.a" -type f -delete
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="7ea131685cd110ec5e0cb7c214b52b75397371e75f011e1410b6770b6a48ca492a02337d86a7be35c852ef94604fe9d6f49634c79d4946df611aaa4f5cbaee28 geos-3.9.1.tar.bz2"
+
+sha512sums="
+192eba83c651e935b3c9a5cc19321285e4d28b9da9d7a1fa15d9471803027e630db7a7ecea96343d9c5f9846d279062ca3694fe47916a4ebf5698ae66dd5210d geos-3.12.1.tar.bz2
+"