aboutsummaryrefslogtreecommitdiffstats
path: root/community/geos
diff options
context:
space:
mode:
Diffstat (limited to 'community/geos')
-rw-r--r--community/geos/10-configure-python3.patch35
-rw-r--r--community/geos/APKBUILD76
2 files changed, 17 insertions, 94 deletions
diff --git a/community/geos/10-configure-python3.patch b/community/geos/10-configure-python3.patch
deleted file mode 100644
index 417d13d492f..00000000000
--- a/community/geos/10-configure-python3.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Author: Holger Jaekel <holger.jaekel@gmx.de>
-Summary: Patch configure script for python3
-----
-
---- a/configure
-+++ b/configure
-@@ -19209,8 +19209,9 @@ $as_echo "$python_path" >&6; }
- # Check for Python library path
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python library path" >&5
- $as_echo_n "checking for Python library path... " >&6; }
-+ PYTHON_MAJOR=`echo $PYTHON_VERSION | cut -d. -f1`
- for i in "$base_python_path/lib/python$PYTHON_VERSION/config/" "$base_python_path/lib/python$PYTHON_VERSION/" "$base_python_path/lib/python/config/" "$base_python_path/lib/python/" "$base_python_path/" "$base_python_path/libs/" ; do
-- python_path=`find $i -name libpython$PYTHON_VERSION.* -print 2> /dev/null | sed "1q"`
-+ python_path=`find $i -name libpython$PYTHON_MAJOR.* -print 2> /dev/null | sed "1q"`
- if test -n "$python_path" ; then
- break
- fi
-@@ -19221,7 +19222,7 @@ $as_echo "$python_path" >&6; }
- if test -z "$python_path" ; then
- as_fn_error $? "cannot find Python library path" "$LINENO" 5
- fi
-- PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_VERSION"
-+ PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_MAJOR"
-
- #
- python_site=`echo $base_python_path | sed "s/config/site-packages/"`
-@@ -19234,7 +19235,7 @@ $as_echo "$python_path" >&6; }
- $as_echo_n "checking python extra libraries... " >&6; }
- PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
- conf = distutils.sysconfig.get_config_var; \
-- print (conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or '')"
-+ print ((conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or ''))"
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHON_EXTRA_LIBS" >&5
- $as_echo "$PYTHON_EXTRA_LIBS" >&6; }`
-
diff --git a/community/geos/APKBUILD b/community/geos/APKBUILD
index 9a8db471a53..5790d41c324 100644
--- a/community/geos/APKBUILD
+++ b/community/geos/APKBUILD
@@ -1,74 +1,32 @@
# Contributor: Eric Kidd <git@randomhacks.net>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=geos
-pkgver=3.8.1
-pkgrel=2
+pkgver=3.12.1
+pkgrel=0
pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
-url="https://trac.osgeo.org/geos/"
-arch="all !s390x !mips !mips64"
+url="https://libgeos.org/"
+arch="all"
license="LGPL-2.1-or-later"
-makedepends="
- swig
- python3-dev
- ruby-dev
- "
-subpackages="
- py3-$pkgname:py3
- ruby-$pkgname:ruby
- $pkgname-dev
- "
-source="
- http://download.osgeo.org/geos/geos-$pkgver.tar.bz2
- 10-configure-python3.patch
- "
+makedepends="cmake samurai"
+subpackages="$pkgname-dev"
+source="https://download.osgeo.org/geos/geos-$pkgver.tar.bz2"
build() {
- case "$CARCH" in
- aarch64*|ppc64le) CXXFLAGS="$CXXFLAGS -ffp-contract=off" ;;
- esac
-
- # fix build on armhf and armv7 with info from
- # https://trac.osgeo.org/geos/ticket/993
- local inline="--enable-inline"
- case "$CARCH" in
- armhf|armv7) inline="--disable-inline" ;;
- esac
-
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- $inline \
- --enable-python \
- --enable-ruby
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON
+ cmake --build build
}
check() {
- make check
+ ctest --test-dir build --output-on-failure -j${JOBS:-2}
}
package() {
- make DESTDIR="$pkgdir" install
- find $pkgdir -name "*.a" -type f -delete
+ DESTDIR="$pkgdir" cmake --install build
}
-py3() {
- pkgdesc="$pkgname Python3 bindings"
-
- install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
-}
-
-ruby() {
- pkgdesc="$pkgname Ruby bindings"
-
- install -d "$subpkgdir"/usr/lib/ruby/vendor_ruby
- mv "$pkgdir"/usr/local/lib/site_ruby/* "$subpkgdir"/usr/lib/ruby/vendor_ruby
- rm -rf "${pkgdir:?}"/usr/local
-}
-sha512sums="1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056 geos-3.8.1.tar.bz2
-a76aceadb30c6a078ef9c671d8335647bd6b94094bd4bdda5958f0d50271552e8f1f7b4e9d4295986f4371a446071c3cc3a446ef520543e820bde83833fea18e 10-configure-python3.patch"
+sha512sums="
+192eba83c651e935b3c9a5cc19321285e4d28b9da9d7a1fa15d9471803027e630db7a7ecea96343d9c5f9846d279062ca3694fe47916a4ebf5698ae66dd5210d geos-3.12.1.tar.bz2
+"