aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geth/APKBUILD')
-rw-r--r--community/geth/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index dc8ca07ae93..bd684d4f860 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -1,18 +1,27 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=geth
-pkgver=1.10.8
-pkgrel=1
+pkgver=1.13.14
+pkgrel=2
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
-arch="all !aarch64 !mips64" # build fails
+arch="all"
license="LGPL-3.0-or-later"
makedepends="go linux-headers"
checkdepends="fuse"
-options="!check chmod-clean"
+options="!check chmod-clean net"
source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
builddir="$srcdir/go-ethereum-$pkgver"
+# secfixes:
+# 1.10.22-r0:
+# - CVE-2022-37450
+
+export GOROOT=/usr/lib/go
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
make
}
@@ -27,5 +36,5 @@ package() {
}
sha512sums="
-6338ad7b3aa6e93fc960f0b8f955a318b3e9e8e839d375076d423ae92dea405557213418e2c083d3d74d389a9a55f75db61a1d3f1609b3789348c5a2e8117395 geth-1.10.8.tar.gz
+80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc geth-1.13.14.tar.gz
"