aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geth/APKBUILD')
-rw-r--r--community/geth/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index 7141a5120f1..bd684d4f860 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -1,21 +1,26 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=geth
-pkgver=1.10.20
+pkgver=1.13.14
pkgrel=2
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
-arch="all !aarch64" # build fails
+arch="all"
license="LGPL-3.0-or-later"
makedepends="go linux-headers"
checkdepends="fuse"
-options="!check chmod-clean"
+options="!check chmod-clean net"
source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
builddir="$srcdir/go-ethereum-$pkgver"
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+# secfixes:
+# 1.10.22-r0:
+# - CVE-2022-37450
+
+export GOROOT=/usr/lib/go
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
make
@@ -31,5 +36,5 @@ package() {
}
sha512sums="
-d544f199239b9e96fe8b07b69d73bdfc05734bbd4b3371fe97a842b131af2dc21492883dc431b57a1b41e14a50408cc6c8af0af9d85c86e28a385fe53d0f54a3 geth-1.10.20.tar.gz
+80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc geth-1.13.14.tar.gz
"