aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geth/APKBUILD')
-rw-r--r--community/geth/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index 2ebe0d2304d..f8d27a0a73a 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -1,18 +1,27 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=geth
-pkgver=1.10.1
-pkgrel=0
+pkgver=1.13.14
+pkgrel=1
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
-arch="all !aarch64 !mips64" # build fails
+arch="all"
license="LGPL-3.0-or-later"
makedepends="go linux-headers"
checkdepends="fuse"
-options="!check chmod-clean"
+options="!check chmod-clean net"
source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
builddir="$srcdir/go-ethereum-$pkgver"
+# secfixes:
+# 1.10.22-r0:
+# - CVE-2022-37450
+
+export GOROOT=/usr/lib/go
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
make
}
@@ -26,4 +35,6 @@ package() {
install -m755 -t "$pkgdir"/usr/bin build/bin/*
}
-sha512sums="94626dbddb4da44e8c6695734cff940f4bbb7baafa23cf34d7fd2a48270d0f6e3df0a171b38df077eba6b4dcdaf526ec12c755a159ef27a5dab8656fe3c013e4 geth-1.10.1.tar.gz"
+sha512sums="
+80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc geth-1.13.14.tar.gz
+"