aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/geth/APKBUILD')
-rw-r--r--community/geth/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index 90e48137398..bd684d4f860 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -1,18 +1,27 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=geth
-pkgver=1.10.17
+pkgver=1.13.14
pkgrel=2
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
-arch="all !aarch64" # build fails
+arch="all"
license="LGPL-3.0-or-later"
makedepends="go linux-headers"
checkdepends="fuse"
-options="!check chmod-clean"
+options="!check chmod-clean net"
source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
builddir="$srcdir/go-ethereum-$pkgver"
+# secfixes:
+# 1.10.22-r0:
+# - CVE-2022-37450
+
+export GOROOT=/usr/lib/go
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
make
}
@@ -27,5 +36,5 @@ package() {
}
sha512sums="
-2f7089dd652a758eebd2f44e2fb07f663b2496139a36bf255f7e1803c7cb87eeb2dfb6837d898bf8535b52e794654cca89ed18bff66d5430ee82af7daf444238 geth-1.10.17.tar.gz
+80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc geth-1.13.14.tar.gz
"