aboutsummaryrefslogtreecommitdiffstats
path: root/community/gexiv2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gexiv2/APKBUILD')
-rw-r--r--community/gexiv2/APKBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/community/gexiv2/APKBUILD b/community/gexiv2/APKBUILD
index 0f774df3202..2647d1ee2cb 100644
--- a/community/gexiv2/APKBUILD
+++ b/community/gexiv2/APKBUILD
@@ -1,16 +1,23 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gexiv2
-pkgver=0.14.0
-pkgrel=1
+pkgver=0.14.2
+pkgrel=4
pkgdesc="GObject-based wrapper around the Exiv2 library"
url="https://wiki.gnome.org/Projects/gexiv2"
arch="all"
license="GPL-2.0-or-later"
-makedepends="exiv2-dev meson py3-gobject3 glib-dev gtk-doc
- gobject-introspection-dev vala"
-subpackages="$pkgname-dev"
+makedepends="
+ exiv2-dev
+ glib-dev
+ gobject-introspection-dev
+ gtk-doc
+ meson
+ py3-gobject3
+ vala
+ "
+subpackages="py3-$pkgname-pyc py3-$pkgname:py3 $pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/gexiv2/${pkgver%.*}/gexiv2-$pkgver.tar.xz"
replaces="libgexiv2"
@@ -19,18 +26,24 @@ build() {
-Dgtk_doc=true \
-Dintrospection=true \
-Dvapi=true \
+ -Dtests="$(want_check && echo true || echo false)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ python3 -m compileall -qf "$pkgdir"/usr/lib
+}
+
+py3() {
+ amove usr/lib/python*
}
sha512sums="
-d745ae2d8ddcf0c8a2a7980eaa489f9b520af54242c5e4ddded9c3ae4a579c824c8cb659bd7e985ffa09f9fe37bdf73d6d9181d456711e0953b73023eb0f9f50 gexiv2-0.14.0.tar.xz
+16536be5180d5f13f549a68f5b701343a1246eca99083e43e6fc700b151614ea80696f931fcbc721b05955173e3206819b593e5b0fcd8ad4fd7d3b287d9c1441 gexiv2-0.14.2.tar.xz
"