aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ghc/APKBUILD')
-rw-r--r--community/ghc/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index 34f956dc2aa..d7be1aac31d 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -7,7 +7,7 @@ pkgrel=0
# Normal non rc candidate
_urlprefix="$pkgver"
_pkgprefix="$pkgname-$pkgver"
-_llvmver=12
+_llvmver=14
pkgdesc="The Glasgow Haskell Compiler"
# Next 5 variables only needed for release candidate testing
#pkgrcver=8.2.2
@@ -52,6 +52,7 @@ source="https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-src.tar.xz
0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
skip-tests.patch
tests-use-iterable-from-collections-abc.patch
+ llvm14.patch
"
prepare() {
@@ -167,4 +168,5 @@ ac2ad793b4d33ea890e236820af4cd10996b47d0f4249c825b31450145cb8195c2be62f2d7942cc3
b71bb7945c6cae3ea324ff1de9576b883f0e63169fbe50d781acc0f4fb694387c43bf7aa1bd1cca236613ff202dd503c4577dc06368614752affdc54a5c62101 0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
3c46fab45a484a96f2166b4331a00708792b8107b697e4ec0cb3d51bcc6b7305142e380e6f1ed3de9f8359482d0392c7639396366afed2dea440087109367d4f skip-tests.patch
c3bc4f872d3903c4446167df1a88ec54cdd712c4b0ea0b0c35487e9b7e5bd7124da0688d1d5fbf26cad932e841f0299ada304e2300c25e01ffe3de10b74e78c1 tests-use-iterable-from-collections-abc.patch
+2e11a83844c4a9f895f60af9f014cd1989eeb4efb6a96576d62aa0abe55792eaf4f4963c05599900edb7ad371745923a4022119a802b3f8905d2c8fcb46697af llvm14.patch
"