aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ghex/APKBUILD')
-rw-r--r--community/ghex/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/ghex/APKBUILD b/community/ghex/APKBUILD
index ebf5f7de536..6efdf0c4161 100644
--- a/community/ghex/APKBUILD
+++ b/community/ghex/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: August Klein <amatcoder@gmail.com>
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=ghex
-pkgver=42.3
+pkgver=45.1
_pkgver=${pkgver%.*}
pkgrel=0
pkgdesc="A hex editor for GNOME"
@@ -9,17 +9,25 @@ url="https://wiki.gnome.org/Apps/Ghex"
arch="all !s390x !riscv64" # gtk4.0
license="GPL-2.0-or-later"
depends="dconf"
-makedepends="desktop-file-utils meson itstool gtk4.0-dev glib-dev at-spi2-core-dev"
+makedepends="
+ at-spi2-core-dev
+ desktop-file-utils
+ glib-dev
+ gtk4.0-dev
+ itstool
+ libadwaita-dev
+ meson
+ "
subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/ghex/$_pkgver/ghex-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -27,5 +35,5 @@ package() {
}
sha512sums="
-9eff44892d203a2a9aab7239d85f61a860458fd7a8b4d7410f94d4f596ca5e2ff269faa81e620e7fc08bebe40c819a4c0cafefb5278121a9f2c8885bfd17c59f ghex-42.3.tar.xz
+308e1dbcdab1a3277b7808f3e0f09af4609e69b263fc7b02ae7a7d71fd47f7c66f7838281b14dd8f3175ec3449dc074a17286961220216374769b790e800a92f ghex-45.1.tar.xz
"