aboutsummaryrefslogtreecommitdiffstats
path: root/community/gi-docgen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gi-docgen/APKBUILD')
-rw-r--r--community/gi-docgen/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/gi-docgen/APKBUILD b/community/gi-docgen/APKBUILD
index 003551e65b0..31a4f88bf7f 100644
--- a/community/gi-docgen/APKBUILD
+++ b/community/gi-docgen/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=gi-docgen
-pkgver=2022.1
-pkgrel=0
+pkgver=2023.3
+pkgrel=1
pkgdesc="A documentation generator for GObject-based libraries"
url="https://gitlab.gnome.org/GNOME/gi-docgen"
arch="noarch"
@@ -11,21 +11,22 @@ depends="
py3-jinja2
py3-markdown
py3-markupsafe
+ py3-packaging
py3-pygments
- py3-toml
py3-typogrify
python3
"
+subpackages="$pkgname-pyc"
makedepends="meson"
source="https://gitlab.gnome.org/GNOME/gi-docgen/-/archive/$pkgver/gi-docgen-$pkgver.tar.gz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -33,5 +34,5 @@ package() {
}
sha512sums="
-93a4e887a764a2bf3e77a48220693c30c0e8b249e1de193c61f20235e514ad206dba4b99c81cd6791e525e6cd406c8dc3508c92fc52f6cc52ecf05632b9a7cb6 gi-docgen-2022.1.tar.gz
+9fbfe97167d83e0f166c6eece5e723dcf6d2a345cdf577a0618c971f3023d7a83d3ded471002a3ca24c2fe94611ceb88781002bacf406543f4a7f3b8608e42e5 gi-docgen-2023.3.tar.gz
"