aboutsummaryrefslogtreecommitdiffstats
path: root/community/giara/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/giara/APKBUILD')
-rw-r--r--community/giara/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/giara/APKBUILD b/community/giara/APKBUILD
new file mode 100644
index 00000000000..66761e50577
--- /dev/null
+++ b/community/giara/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Newbyte <newbie13xd@gmail.com>
+# Maintainer: Newbyte <newbie13xd@gmail.com>
+pkgname=giara
+pkgver=0.3
+pkgrel=0
+pkgdesc="reddit app for GNOME, created with mobile Linux in mind."
+url="https://gitlab.gnome.org/World/giara"
+arch="noarch !s390x !mips !mips64" # due to libhandy1, in turn due to ibus
+license="GPL-3.0-or-later"
+depends="
+ py3-beautifulsoup4
+ py3-cairo
+ py3-dateutil
+ py3-gobject3
+ py3-mistune
+ py3-pillow
+ py3-praw
+ py3-requests
+ gtksourceview4
+ gtk+3.0
+ libhandy1
+ python3
+ webkit2gtk
+ "
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ meson
+ "
+source="$pkgname-$pkgver.tar.gz::https://gitlab.gnome.org/World/giara/-/archive/$pkgver/giara-$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ meson compile -j 2 -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="b245379a3975647ab0469abe404527976a65a856241bc268eb4edb33ad049d98e5f6de7df03a8e16ed8f67fcb2849498072a13e217837cb78dc6feda1f63582e giara-0.3.tar.gz"