aboutsummaryrefslogtreecommitdiffstats
path: root/community/ginkgo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ginkgo/APKBUILD')
-rw-r--r--community/ginkgo/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/ginkgo/APKBUILD b/community/ginkgo/APKBUILD
index 8bc31ce6733..e22486b45da 100644
--- a/community/ginkgo/APKBUILD
+++ b/community/ginkgo/APKBUILD
@@ -1,33 +1,38 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=ginkgo
-pkgver=2.1.4
-pkgrel=1
+pkgver=2.16.0
+pkgrel=0
pkgdesc="Modern Testing Framework for Go"
url="https://onsi.github.io/ginkgo/"
license="MIT"
-arch="all !armv7 !armhf !x86" # FTBFS on 32-bit arches
+arch="all"
makedepends="go"
-source="https://github.com/onsi/ginkgo/archive/v$pkgver/ginkgo-$pkgver.tar.gz"
+source="https://github.com/onsi/ginkgo/archive/v$pkgver/ginkgo-$pkgver.tar.gz
+ tests.patch
+ "
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GOPATH="$srcdir"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v -ldflags "-s -w" -o bin/ginkgo ./ginkgo
+ go build -v -o bin/ginkgo ./ginkgo
}
check() {
# integration tests are slow
- # types fail on CodeLocation tests
- ./bin/ginkgo -r --randomize-all --randomize-suites \
- --skip-package ./integration,./types
+ # CodeLocation tests access local files inside project root, so they don't work with -trimpath
+ GOFLAGS="${GOFLAGS/-trimpath/}" \
+ ./bin/ginkgo -r --randomize-all --randomize-suites \
+ --skip-package ./integration
}
package() {
- install -Dm755 bin/ginkgo "$pkgdir"/usr/bin/ginkgo
+ install -Dm755 bin/ginkgo -t "$pkgdir"/usr/bin/
}
sha512sums="
-bbbc101d38b528bd5e9d4676f796901f1d9d13257f66d90c2ebbd4bebe1051aedbf97799d0b5ee06eb384afa707340a5bc387ff3f23353e6c17e58df7ace0306 ginkgo-2.1.4.tar.gz
+13e760884b181c016ab600cd7ab06d86de841063a0530d8d4b83b7f52cbf248d1749b59c133b180f9fdbb5a4db85cec3a31a54c59b384f45a79b243f8b553122 ginkgo-2.16.0.tar.gz
+2fe515438583a51dbd92912a761063882788b3d001d37073986d81b9d4076e0381ee1981623cbf603fb70b59efb60bf941d577ecb8d5af97027d1877c7e164cc tests.patch
"