aboutsummaryrefslogtreecommitdiffstats
path: root/community/gir-to-d/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gir-to-d/APKBUILD')
-rw-r--r--community/gir-to-d/APKBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/community/gir-to-d/APKBUILD b/community/gir-to-d/APKBUILD
index c75623ca5c1..4084e37597a 100644
--- a/community/gir-to-d/APKBUILD
+++ b/community/gir-to-d/APKBUILD
@@ -1,27 +1,28 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gir-to-d
-pkgver=0.21.0
-pkgrel=1
+pkgver=0.23.1
+pkgrel=4
pkgdesc="Create D bindings from GObject introspection files"
url="https://github.com/gtkd-developers/gir-to-d"
-# gdc is broken on 32bit arches
-aarch="aarch64 x86_64"
+# limited by ldc
+arch="aarch64 x86_64"
license="LGPL-3.0-or-later"
-makedepends="meson gcc-gdc"
+makedepends="meson ldc"
options="!check" # no tests
-source="https://github.com/gtkd-developers/gir-to-d/archive/v$pkgver/gir-to-d-$pkgver.tar.gz
- glib.patch::https://github.com/gtkd-developers/gir-to-d/commit/b5a463ce6a1f41979030ed43b33c266fb1a352ae.patch
- "
+source="https://github.com/gtkd-developers/gir-to-d/archive/v$pkgver/gir-to-d-$pkgver.tar.gz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ # Pass --allinst to ldc to work around an undefined reference build issue
+ # https://github.com/ldc-developers/ldc/issues/4000
+ LDFLAGS= abuild-meson -Dd_args="--allinst" . output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="378a5c1cb1ec909fc39f1cc00b2479a0d826c3bdfe31b535e68719e4ccc74db548b670700dbf78eced417777477d1bcf5aad1cbe2bc15049f1ec52666c16a9da gir-to-d-0.21.0.tar.gz
-b3966192c0d04dac2154a721a0e637c751b113b50ea8f5ff4fd31a37c4d702509fded34aca7a934885e043df0218a232931cf4d28bd61549a39d421e57adaff6 glib.patch"
+sha512sums="
+d1cfb906cd094acdf134a9a748fbd71fdbd4a26ce4d1696be356eb0c1c12edf4a96c73b7ca79da46c36f7e0ee15645991364b2bb2e1cbc46e8023233d4327060 gir-to-d-0.23.1.tar.gz
+"