aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-branchless/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-branchless/APKBUILD')
-rw-r--r--community/git-branchless/APKBUILD45
1 files changed, 30 insertions, 15 deletions
diff --git a/community/git-branchless/APKBUILD b/community/git-branchless/APKBUILD
index 0ef4c96c9ff..1c900397820 100644
--- a/community/git-branchless/APKBUILD
+++ b/community/git-branchless/APKBUILD
@@ -1,50 +1,65 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-branchless
-pkgver=0.3.12
+pkgver=0.8.0
pkgrel=0
pkgdesc="Suite of tools to help you visualize, navigate, manipulate, and repair your commit graph"
url="https://github.com/arxanas/git-branchless"
-arch="aarch64 armhf armv7 ppc64le x86 x86_64" # blocked by rust/cargo
+# riscv64: test fails
+# s390x: nix crate fails to build
+arch="all !riscv64 !s390x"
license="GPL-2.0-only"
makedepends="
cargo
+ cargo-auditable
libgit2-dev
libssh2-dev
- openssl-dev
+ openssl-dev>3
sqlite-dev
"
-checkdepends="git"
+checkdepends="
+ bash
+ git
+ "
source="https://github.com/arxanas/git-branchless/archive/v$pkgver/git-branchless-$pkgver.tar.gz
unbundle-sqlite.patch
"
-
-export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
-export CARGO_PROFILE_RELEASE_LTO="true"
-export CARGO_PROFILE_RELEASE_OPT_LEVEL="s"
-export CARGO_PROFILE_RELEASE_PANIC="abort"
+options="net"
export LIBSSH2_SYS_USE_PKG_CONFIG=1 # use system libssh2
prepare() {
default_prepare
- cargo fetch --locked
+ # Rust target triple.
+ local target=$(rustc -vV | sed -n 's/host: //p')
+
+ # Build against system-provided libs
+ mkdir -p .cargo
+ cat >> .cargo/config.toml <<-EOF
+ [target.$target]
+ git2 = { rustc-link-lib = ["git2"] }
+ EOF
+
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
check() {
- # NOTE: Skipped tests hang on CI, see
+ # NOTE: The first two skipped tests hang on CI, see
# https://github.com/arxanas/git-branchless/pull/159 for more info.
+ # The other two are probably broken.
TEST_GIT_EXEC_PATH=$(git --exec-path) \
TEST_GIT=$(which git) \
RUST_BACKTRACE=1 \
cargo test --workspace --frozen -- \
--skip=test_checkout_pty \
- --skip=test_next_ambiguous_interactive
+ --skip=test_next_ambiguous_interactive \
+ --skip=command::test_test::test_test_config_strategy \
+ --skip=command::test_test::test_test_verbosity
}
package() {
@@ -52,6 +67,6 @@ package() {
}
sha512sums="
-6b09a419aba131dbf1ef15c157b9f795ce1c6d2435d6f6af54e78c68aaf7f9f3fa39374db45437d3ef022ae7106513e7b596a0f7c25051ad15422e9fed6b4423 git-branchless-0.3.12.tar.gz
-b89b75f7ffe38d3b95f6ea1263993a5d6ea152b79a3acc5866f575361be7629f6e2c8f31e6d6d23b9a319bd217da5091dcc9d6a096069551ff972f19c090019f unbundle-sqlite.patch
+ad3435948ffabe256fff2f7b0fe654818fc280049fea0df845ce593ccd713faf5988c843062cfae28c10641c84ed15abaeb0ae774d21e88364f83c0c82852964 git-branchless-0.8.0.tar.gz
+a6edb671e188bb53cbe43c760c922233ed9e2e7cfdc3d2a32a020dfb847cff413a0c30333d03e76acf920459c438672cd2b975d515b57bfddd1ecc1bbceb1de4 unbundle-sqlite.patch
"