aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-branchless/unbundle-sqlite.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-branchless/unbundle-sqlite.patch')
-rw-r--r--community/git-branchless/unbundle-sqlite.patch37
1 files changed, 13 insertions, 24 deletions
diff --git a/community/git-branchless/unbundle-sqlite.patch b/community/git-branchless/unbundle-sqlite.patch
index 2112a071f81..e59e6fb291c 100644
--- a/community/git-branchless/unbundle-sqlite.patch
+++ b/community/git-branchless/unbundle-sqlite.patch
@@ -1,32 +1,21 @@
--- a/Cargo.lock
+++ b/Cargo.lock
-@@ -1267,7 +1267,6 @@
+@@ -2088,7 +2087,6 @@
source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "898745e570c7d0453cc1fbc4a701eb6c662ed54e8fec8b7d14be137ebeeb9d14"
+ checksum = "afc22eff61b133b115c6e8c74e818c628d6d5e7a502afea6f64dee076dd94326"
dependencies = [
- "cc",
"pkg-config",
"vcpkg",
]
---- a/git-branchless/Cargo.toml
-+++ b/git-branchless/Cargo.toml
-@@ -37,7 +37,7 @@
- path-slash = "0.1.4"
- rayon = "1.5.1"
- regex = "1.5.5"
--rusqlite = { version = "0.27.0", features = ["bundled"] }
-+rusqlite = { version = "0.27.0" }
- tracing = "0.1.32"
- tracing-chrome = "0.5.0"
- tracing-error = "0.2.0"
---- a/git-branchless-lib/Cargo.toml
-+++ b/git-branchless-lib/Cargo.toml
-@@ -53,7 +53,7 @@
- os_str_bytes = "6.0.0"
- rayon = "1.5.1"
- regex = "1.5.5"
--rusqlite = { version = "0.27.0", features = ["bundled"] }
-+rusqlite = { version = "0.27.0" }
- tempfile = "3.3.0"
- textwrap = "0.15.0"
- tracing = "0.1.32"
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -84,7 +84,7 @@
+ portable-pty = "0.8.1"
+ rayon = "1.7.0"
+ regex = "1.9.3"
+-rusqlite = { version = "0.29.0", features = ["bundled"] }
++rusqlite = { version = "0.29.0" }
+ scm-bisect = { version = "0.1.0", path = "scm-bisect" }
+ scm-record = { version = "0.1.0", path = "scm-record" }
+ serde = { version = "1.0.168", features = ["derive"] }